RUTX11 cannot update modem 2

Continued from this thread:

I updated to latest RUTX_R_00.07.07.1 and then did a factory reset.

After that I tried to update modem again and I still get same error.

PS.Why are the topics automatically closed?

Hello,

You can try updating the modem via the dfota command using SSH/CLI.

2024-06-12-09-10-07-192.168.50.1 (root)

Please note that topics are automatically closed by the system 15 days after their creation.

Best regards,

root@RUTX11:~# dfota -u
Preparing for gsm.modem0 update!
Searching for updates...
Update found! Update size: 25761882
Preparing system for update!
sh: out of range
Not enough memory in modem filesystem! ErrorCode: 171
Reseting modems due error!
Update script done!

I find the closing of topics to be unhelpful because it blocks the possibility of adding to pertinent topics. You basically have to start over again whereas leaving them open allows a history to develop and contributions to be added. Also, I will no longer update unless there is something I specifically need and I will try that on a test router for a few weeks minimum.

Hi,

We can upgrade your modem using a file. I will share it with you on a different platform. Instructions for accessing it have been sent to the email you used to register for this forum.

To upgrade the modem using the file, follow these steps:

dfota -f /<filelocation>

If you’re using a Windows PC, you can upload the file to your router using the WinSCP program.

Best regards,