Wireguard doesn't work from web-interface

I followed this page to setup my RUTX11 to act as a wireguard node.


I get nothing shown when I type wg in the terminal as root.

I tried going full wireguard in commandline in the router and it works perfectly.

# wg
interface: wg0
  public key: XXXXXXXXXXX
  private key: (hidden)
  listening port: 51820

  allowed ips:
  latest handshake: 1 minute, 6 seconds ago
  transfer: 2.18 KiB received, 2.21 KiB sent

I’m using the latest RUTX11 firmware.

I would rather be able to use the web-gui at teltonika as it makes it easier to manage


I tried doing the same config using RUTX11 running the firmware (07.05.04) and I am able to established a wireguard tunnel from the other peer.



Below are screenshots of my config which is the same as the one in the wiki article
Peer 1

Peer 2

If you have the same configuration (you followed the instructions on the wiki article) and the same issue persist.
I would recommend reflashing the firmware of the device and configure it again. You can do this by upgrading the firmware without keeping the settings.

Hope this helps, and let me know the results :slight_smile:

Best regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.