Wireguard doesn’t work from web-interface 2

Continuation from:

I never got around to factory reset my RUTX11 and try again.

I have flashed the latest fw and done a complete reset and I still get the same problem that I get no wireguard network adapter created if I enter as exactly in the wiki page linked.

I tried creating my network manually with uci and was also able to create the network.

If I just did this commands I was able to get my wireguard network named “wireguard” to be visible when running “wg” command:

uci delete network.wireguard.device
uci commit network
/etc/init.d/network restart
root@RUTX11:~# wg
interface: wireguard
  public key: xxxx
  private key: (hidden)
  listening port: 51820

peer: yyyy
  allowed ips: 192.168.2.0/24, 2001:db8::4/128

It seems now the device will be named as the same as what I named it in the GUI.

This is my uci show network:

network.wireguard=interface
network.wireguard.proto='wireguard'
network.wireguard.private_key='xxx'
network.wireguard.public_key='yyy'
network.wireguard.addresses='192.168.2.1/24' '2001:db8::1/128'
network.wireguard.disabled='0'
network.wireguard.listen_port='51820'

network.pixel8=wireguard_wireguard
network.pixel8.allowed_ips='192.168.2.4/24' '2001:db08::4/128'
network.pixel8.public_key='zzz'
network.pixel8.tunlink='any'
network.pixel8.route_allowed_ips='1'

If I readd the line I removed my network link is not visible again:

root@RUTX11:~# uci set network.wireguard.device='wg0'
root@RUTX11:~# uci commit network
root@RUTX11:~# /etc/init.d/network restart
{
	"state": "OK"
}
root@RUTX11:~# wg
root@RUTX11:~#

Hi,

Did you follow the tutorial? Can you show me a screenshot of your WireGuard settings?

Also, don’t forget to enable the WireGuard instance; otherwise, it won’t appear as an active interface.

Best regards,

Aye, I followed the tutorial.



Keys are just modified and not saved obviously