Where is the python pip pakage?

Hi.

Trying to install pip, I need it badly to develop python stuff, but Teltonika removed it ?! It have been included before I think… or is it in some other module?

Using firmware Latest to download from server as of 2024-01-16 on RUTX50

opkg update
opkg list , Then I only see this python stuff to install

python3 - 3.9.7-2 - This package contains the (almost) full Python install.

It’s python3-light + all other packages.

python3-asyncio - 3.9.7-2 - Python 3.9 asyncio module

python3-base - 3.9.7-2 - This package contains only the interpreter and the bare minimum for the interpreter to start.

python3-cgi - 3.9.7-2 - Python 3.9 cgi module

python3-cgitb - 3.9.7-2 - Python 3.9 cgitb module

python3-codecs - 3.9.7-2 - Python 3.9 codecs + unicode support

python3-ctypes - 3.9.7-2 - Python 3.9 ctypes module

python3-decimal - 3.9.7-2 - Python 3.9 decimal module

python3-distutils - 3.9.7-2 - Python 3.9 distutils module

python3-email - 3.9.7-2 - Python 3.9 email module

python3-light - 3.9.7-2 - This package is essentially the python3-base package plus a few of the rarely used (and big) libraries stripped out into separate packages.

python3-logging - 3.9.7-2 - Python 3.9 logging module

python3-multiprocessing - 3.9.7-2 - Python 3.9 multiprocessing

python3-ncurses - 3.9.7-2 - Python 3.9 ncurses module

python3-openssl - 3.9.7-2 - Python 3.9 SSL module

python3-pydoc - 3.9.7-2 - Python 3.9 pydoc module

python3-readline - 3.9.7-2 - Python 3.9 readline module

python3-sqlite3 - 3.9.7-2 - Python 3.9 sqlite3 module

python3-unittest - 3.9.7-2 - Python 3.9 unittest module

python3-urllib - 3.9.7-2 - Python 3.9 URL library module

python3-xml - 3.9.7-2 - Python 3.9 xml libs

Hello,

You can still access OpenWrt repositories independently. There’s a post explaining how others are doing it: Link to the post.

Regards,

Marijus

Hi Marijus.
When I click your link it’s showing my own post, please give me the correct link to a post explaining how I can add other repositories.

Hello,

I’ve fixed the link, so it should work correctly now.

Regards,

Marijus

Thanks what set me into the right direction.

This was the final solution:

#updating the openwrt dist feed
opkg -e /etc/opkg/openwrt/distfeeds.conf update

#installing real mosquitto client. Worked great. Should be included in teltonikas kernal!
opkg -e /etc/opkg/openwrt/distfeeds.conf install mosquitto-client-ssl

#testing the mqtt client. Worked, finally I can send any MQTT message I want from CLI
mosquitto_pub -h myserver.com -p myportnumer -t my_topic -m “my_message”

#installed the pip so I can developy my own functionallity!!!
opkg -e /etc/opkg/openwrt/distfeeds.conf install python3-pip

1 Like

Hi!

I’m happy to help. Good luck developing Python scripts :snake: .

Best regards,

Marijus

This topic was automatically closed after 15 days. New replies are no longer allowed.