TRB500 very slow connection to 4g/5g


I have read that many people have the same problem as me and I also can’t get my trb500 to work as expected.
My iPhone is at approx: 350Mbits and the TRB500 is at max 100Mbits.
“Telia” as operator. In the center of Stockholm, Sweden.

Can you look at my logs and see if anything is wrong?


Here my logs:

FW version

Device: TRB500
Kernel: 4.14.328
Firmware: TRB500_R_00.07.06.1
Build: 0f141b8753
Build date: 2024-01-02 11:43:07

root@TRB500:~# gsmctl -A ‘AT+QENG=“SERVINGCELL”’
+QENG: “servingcell”,“NOCONN”
+QENG: “LTE”,“FDD”,240,01,35B7416,145,6300,20,3,3,9,-57,-9,-26,18,12,-400,-
+QENG: “NR5G-NSA”,240,01,139,-77,28,-12,634080,78,12,255

root@TRB500:~# gsmctl -A ‘AT+QCAINFO’
+QCAINFO: “PCC”,6300,50,“LTE BAND 20”,1,145,-58,-6,-35,22
+QCAINFO: “SCC”,1300,100,“LTE BAND 3”,1,481,-77,-9,-59,11,0,-,-
+QCAINFO: “SCC”,3150,100,“LTE BAND 7”,1,481,-88,-11,-64,8,0,-,-
+QCAINFO: “SCC”,1471,75,“LTE BAND 3”,1,481,-78,-16,-53,3,0,-,-
+QCAINFO: “SCC”,634080,12,“NR5G BAND 78”,139

root@TRB500:~# gsmctl -A ‘AT+QENG=“SERVINGCELL”’
+QENG: “servingcell”,“NOCONN”
+QENG: “LTE”,“FDD”,240,01,35B7416,145,6300,20,3,3,9,-58,-8,-32,19,15,-380,-
+QENG: “NR5G-NSA”,240,01,139,-77,29,-12,634080,78,12,255

I have now updated to todays latest [TRB500_R_00.07.06.3_WEBUI.bin] but same issue.


I don’t think your problem is the same as that encountered by other users since normally a restart of the router would allow it to return to its normal speed for about 1 hour then it would be limited to 220 Mbits,

but you never know, The firmware “12A08” does not have any bug fixes,

it is only the most recent version such as RG501QEUAAR12A09M4G_04.200.04. 200 or RG501QEUAAR12A10M4G_04.200.04.200 which has the bug fix,

but I don’t know if I have the right to give you the download link to the firmware RG501QEUAAR12A10M4G_04.200.04.200 since it is not an official Teltonika firmware,
you can find this topic here

Best regards,

1 Like


Your signal parameters seem quite good, but it’s hard to interpret them in the CLI format. Could you upload a screenshot of the WebUI of your device with sensitive information removed? It could look like so:

I’d highly suggest avoiding using modem_updater and installing unofficial firmware, as that will void the warranty for the device, and the currently available modem updates will not increase the throughput.

1 Like

Your issue is likely not the same as mine. But still if you want to try the update, you can find my contact info in the topic linked above. I do not wish to distribute the file publicly due to it being unofficial.

1 Like

I had to change location. I’m not in Stockholm city anymore. So new place and not as good signal as in the city.
But my iPhone is still at about 350 Mbit


Once that firmware from Quectel is fully tested by our RnD team, I will upload the binary file here:

However, for now we advise against using it, as it may have stability or other issues.

@MrEkero Even an iPhone should achieve much greater speeds with these parameters, so currently I suspect that the issue here is cell tower load or that the carrier backbone is at capacity. Could you clarify what speeds the TRB500 is getting in this location? Make sure to test the speed with PC connected to the TRB500 and not using the WebUI speed testing utility built into the TRB.

Best regards,

1 Like

tb500 has the same performance here as in city. approximately 100 Mbit down and 60 Mbit up.
that seems to be what the trb500 can handle right now.


100Mbps sounds close to 100Base-T connection limit. Could you try using a different cable when testing on your PC? Also, could you make sure the tests on the iPhone and the TRB500 are performed to the same server?

Best regards,

1 Like

I have tried several cables and also connected the same computer with the same cable to the switch to my fiber connection. On the fiber connection I have > 800 Mbit.
Yes, it is to the same server that I have tested.

I agree, it seems to be a connection limit at 100mbit.

I contacted the operator (Telia) and asked them to troubleshoot. They pushed new settings to the SIM card and now I have the same speed as my iPhone.
I should have tried the sim card in my iphone right away. Im sorry.

Case closed!

thank you for your time and patience!

Glad to hear that!
Hope that the TRB500 will serve you well.

Best regards,

Hello, It’s my first post here and the truth is I’m having a hard time with a TRB500 in bridge mode achieving maximum 150-170 Mbps download consistently. Another 5G gateway at the exact same spot, at the same time, against the same servers reaches 350-380 Mbps easily. Some say it’s the bridge mode that causes such behavior. My TRB500 runs on the latest firmware (TRB500_R_00.07.06.3) so i figure it’s something about its modem’s firmware. I would very much appreciate any help on this one… Is it possible i have a link of the latest official modem firmware available just like we all do for the device’s? It’s so sad when an industrial device like that faces such problems… Thanks in advance…

I am experiencing the same issue with bridge as you. im using nat for now and waiting for update.

Thank you so much for replying… I was hoping that you should have found a solution by now… It seems that the bug relies in modem’s firmware which is why i’ m trying to find an official way to download the latest updates for that just like we all do when a device firmware is released… If you have any information about that please let me know. I’ve seen topics referencing modem firmware upgrades here and there but I think we all need an official way to do so…

This topic was automatically closed after 15 days. New replies are no longer allowed.