TRB500 no connection on 5G since update

I am using TRB500 for few months now in a place where there is always good 5G connection. It was working and connecting on 5G for months both with provided antennas and also with external ones. Base station is just around 300 - 400 meters away and I do have a good visibility without any obstructions. Signal strength is excellent. Recently, and I believe that it was after last few firmware updates it stopped to connect on 5G, and now I get just 4G+. I tried to reset several times, tried to change SIM card - but it’s always the same. In same place I can get 5G signal with my phone without issue even with the SIM card from the TRB. What could have gone wrong?


Indeed, I was able to replicate the issue and have reported it to our RnD team to look into.
Thank you for bringing this up!

Best regards,

Forgot to mention, this seems to be a WebUI and LED issue only, as the device is connected to 5G, just does not report it.

I am not sure about that because the speed also indicates that it is not on 5G. This is actually how I’ve started to explore this issue. Can I provide some logs or anything else that can help?

Please log into the CLI (System → CLI) with the username root, and the same password as the WebUI. Then run the command gsmctl -A 'AT+QENG="SERVINGCELL"' and post the output here. For privacy reasons, I’d recommend blurring CellID for the LTE line. Explanation of the returned values can be found here: Locking Devices to a Mobile Cell - Teltonika Networks Wiki.
Best regards,

root@Teltonika-TRB500:~# gsmctl -A 'AT+QENG="SERVINGCELL"'
+QENG: "servingcell","NOCONN"
+QENG: "LTE","FDD",219,10,******,406,6225,20,4,4,99,-77,-15,-45,9,5,100,-

The device is connected to n28 5G band, so the speed issues could be temporary on the carrier side, as the only issue the update could have caused is the visualization of 5G connection. Since n28 is intended for coverage, it may not deliver the amazing 5G speeds promised by the carriers. Perhaps you remember what 5G band was used before the update?

Best regards,

Unfortunately not. I remember that it was 5G and the speed were around 150 mbits, now we can barely touch 20-30 mbits.

Please post the output of the command gsmctl -A 'AT+QCAINFO'. This command will show the bands that the TRB500 is using, as from what I can see now, you are using B20 as the primary LTE band, and n28 as a 5G band. If there are no other LTE bands, these would be the expected speeds with your current signal parameters.
Additionally, make sure to run the speed test on a LAN device (not the TRB itself), and use the same speed test server as before.

Best regards,

Here it is:

root@Teltonika-TRB500:~# gsmctl -A 'AT+QCAINFO'
+QCAINFO: "PCC",6225,75,"LTE BAND 20",1,406,-78,-13,-46,-1
+QCAINFO: "SCC",1749,100,"LTE BAND 3",1,256,-82,-10,-64,9

Perhaps you could try downgrading and checking the speeds on 07.04.3? Make sure you are using the same speed test server.
Additionally, speeds could be tested during different times of day, as on evenings cell towers are often overloaded and cannot deliver the full speeds.

Well, made the downgrade. 5G is visible again but the speeds also improved.


Tried few times, always around same numbers.

Had to split in two, since I can only one picture send per post:



All speed tests are made from my Ubiquity router sitting just after the TRB500.

Please post the output of the previous commands on the 07.04.3 as well. Thank you.

root@Teltonika-TRB500:~# gsmctl -A 'AT+QENG="SERVINGCELL"'
+QENG: "servingcell","NOCONN"
+QENG: "LTE","FDD",219,10,******,406,6225,20,4,4,99,-78,-16,-45,8,4,110,-

root@Teltonika-TRB500:~# gsmctl -A 'AT+QCAINFO'
+QCAINFO: "PCC",6225,75,"LTE BAND 20",1,406,-78,-14,-43,-3
+QCAINFO: "SCC",500,100,"LTE BAND 1",1,352,-82,-11,-63,7
+QCAINFO: "SCC",1749,100,"LTE BAND 3",1,256,-82,-11,-63,8


Your device is connecting to n78 band on the older firmware, which is more likely to be a coincidence rather that something is broken. I’d recommend updating to the latest, and blacklisting the n28 band, to force the device to connect to the faster n78 band. Additionally, B1 seems to be missing after the update, but it may simply take some time for the device to add this band as SCC.
If this does not help, I’d recommend sticking to 07.04.3 until 07.05 comes out.

Best regards,

Yes, you are right. Back to newer image (07.04.5) and the outputs are the same as with the old one. So it seems that it was coincidence or maybe the fact that I reloaded TRB after upgrade got different (better) results.

How can I blacklist band 28?

Band lock can be configured as per this manual: Band Lock - Teltonika Networks Wiki
So to blacklist the n28 band, in the Mobile menu, select the network type as 4G+5G, and select all 4G bands, and all 5G bands except n28:

Best regards,

1 Like

Just to report that after removing band N28 and going back to the latest firmware everything looks good now for few days. We didn’t see any further interruption of service or slower speeds. Now it just about displaying wrong information on the web console, still sayin’ it is a 4g+ connection. Do you have any estimate when the new firmware could be expected that will fix the visual part?

The issue with incorrect information being displayed only affects the very early production units. It’s not an issue with RutOS, rather with the internal modem firmware. To update it, the TRB500 needs to have it’s Ethernet port reconfigured to WAN, and it needs to have a stable external connection to the internet.

However, I should note once again, that this is only a visual issue, and does not affect the functionality of the device. If you’d still like to undergo the update process, we will need to provide some information, which cannot be shared publicly. Thus you will need to contact your sales representative or a reseller to establish a private communication channel with us. If this is not an option, please fill out the Contact Us form here: Teltonika Networks - LTE Routers, Gateways & Modems for IoT
Provide the URL of this thread, and my colleagues will help you out with the update process.

Best regards,