RUTX50 - Wireless packet corruption/resend/RST not seen LAN<->WAN

following on from this post I have done some packet captures and the situation is:

  • Wired LAN device ,through to WAN device works (ssh / vnc etc)
  • Wireless through to WAN device works and then stops. Multiple retransmittions and ultimate fail.

This is not related to the WAN devices as they all exhibit the same behaviour. is WAN address of RUTX50 is client deivce on WAN network is client wifi laptop

I would really appreciate Teltonika’s input to this issue which is only occuring on WIFI and not LAN.
Turning off / changing Attack Prevention does not fix this issue.



Is this issue occurring with the 7.7.1 Firmware, or did it start with a previous firmware version? Have you attempted the same process with wireless-to-wireless communication? It’s possible that this is a wireless issue rather than a WAN issue.

Best regards,

Hi Marijus, thank you for the reply.
The unit is brand new and I updated right away. I have tested it with RUTX_R_00.07.06.10 but still occurs.

The devices are wired, so no I have not. I will try wireless-wireless.

As the issue does not occur when the initiating host is wired into the RUTX50, I susspect it is.
I have tried changing the wireless bands also but will try 5Ghz (as tests were on 2.4Ghz)

End host = (on ADSL LAN via switch)


RUTX50 WAN = (plugged into ADSL via switch)
WiFi laptop = (on RUTX50 2.4Ghz)

No other configuration has been made to the RUTX50 apart from running through the setup.
It does have a 4G connection also. I have tried with this disabled also.
Could it be something to do with MWAN3 in the background still, even with no config ?
p.s. all devices on the same LAN before this new setup work 100% with no issues / timeouts etc

@Marijus FYI, this also occurs wireless to wireless. That is, Wireless on RUTX50 and Wireless on ADSL router.
This is definatly an issue with the wireless on RUTX50 device as it does not occur with wired connection.

Are you able to replicate this at-all ?


I have tested connected via 5G on the RUTX, via different wireless clients and ity still occurs.
This is not just SSH or VNC. it is any port that sends data quickly. For ports that send small amounts of data slowly, it does not happen.

Can someone please advise trobleshooting or next steps to resolve this issue which appears to be with the wifi on this device.

Thank you


Does this only impact transmission failure, or do wireless devices get disconnected from Wi-Fi as well?

You might also want to check if your Wi-Fi is on a congested band. This problem could be caused by other wireless devices operating on the same band. To check the wireless spectrum, go to Status → Wireless → Channel Analysis. You can change the band of your wireless interface by going to Network → Wireless → Radio.

Best regards,

The devices can still ping when this occurs.
This is a packet level block that appears to be occuring.
The wireless is not congested and has been changed away from others as well on the same band as others and still occurs.

Are there any othere inspections / DDoS / rate limits that are put on , that are not able to be disabled from the web interface (I’ve tried the) ?
I’ve also tried setting the fragmentation settings to 2346 and CTS 2347 but this made no change.

It is not just for encrypted conenctions, I have tried to a local service TCP port that streams text at quite a few lines per second and this also gets to around 6-12k of data and stops. It’s often 6-7k but has been as low as 2k.
TCP ports that do not send rapidly are not effected and seem to be ok (until they send rapidly)

Is anyone on this forum able to reproduce my fault please?
As it stands, this does not work for what I want, which is hugely dissapointing.

Hello, could you try to disable hardware NAT in Network->Firewall? And reboot router after disabling.
Do you see any errors about wifi in System log?

Thank you for your reply.

looking with logread, there are no errors when the error occurs.
This is the only thing that seems slightly related to wifi and is on boot

Mon May 13 13:40:23 2024 kern.warn kernel: [  328.161113] netlink: 'iw': attribute type 302 has an invalid length.
Mon May 13 13:40:23 2024 daemon.notice wpa_supplicant[1773]: Set new config for phy phy1

Disabling the hardware NAT, does improve the situation. I am not sure what the hardware is capable of but it obviously has issues with this?

Does Teltonika have any input for this please?

This topic was automatically closed after 15 days. New replies are no longer allowed.


It seems this issue is more serious than we initially thought. Our R&D department is currently investigating it. We will update you as soon as we have more information. Thank you for bringing this to our attention.

Kind regards,

@Marijus Thank you for your reply and confirmation that there is an underlying issue.
I’m glad you have managed to reproduce it and have identified there is an issue.
I await your finding.



The issue has been investigated and is now being worked on. Fixes should be coming in the upcoming firmware release.

Kind regards,

1 Like