Devices on WAN - packets dissapearing after initial connect

Hi all,

I have an issue where trying to SSH to a device on the WAN side connects but then packets stop after 5-10 seconds.

i have a RUTX50 (fw;RUTX_R_00.07.07.1) in the following configuration.

www                    4G
 \                     |
  ADSLRouter1---(wan)RUTX50--Wifi--laptop (putty)
  |
  SSH-device

The config is totally default. Nothing setup ; just the initial wizard.
I get connected, sometimes I can send command (ls etc) and then it just stops. the connection freezes and then it disconnects a little while later.

SSH connections to the WWW are not affected.
I’ve tried turning of some spoofing settings but nothing have changed.
I’ve also tried adding manual routes from the SSH-Device back to the RUT-LAN

This is really frustrating and I’m not sure what is causing it ?
VNC is also affected but web ports don’t seem to be.

Does anyone have any ideas what is causing WAN devices to get cut off like this?

thank you.

Hi there,

I have a few questions to start with. How is your SSH device connected to the ADSL router? Are they on the same LAN network? Also, how are you attempting to connect to another device? Are you using a public static IP or something different?

Additionally, were you able to successfully connect using the previous firmware version?

Best regards,

Hi Marijus, thank you for your reply.
For information, it is not only SSH. VNC to these devices (pi’s) also does not work in the same way - starts then stops with packet resends.

The devices are wired into a switch, which the RUTX50’s WAN is also plugged into, which is into the ADSL router’s LAN ports.

I am attempting to connect via putty, ssh (windows terminal) or via VNC (port 5900). All have the same effect.
I however have noticed that a TCP telnet-style connection to an application on the device does not exhibit the same behaviour. Possbily because it it not passing more than a few bytes of traffic at very interspersed periods.

The wireless laptop is DHCP via the RUTX50 Wi-fi (2.4Ghz). The end devices are static, with a DGW of the ADSL router.

As mentioned in my other post with pcap’s, it also happens on RUTX_R_00.07.06.10

thanks and regards
Steve

This topic was automatically closed after 15 days. New replies are no longer allowed.