RUTX50 - Ports, interfaces, devices; logical and physical - anyone can explain?

Can someone explain the very odd to me, naming convention used in the RUTX50? I’m asking because in your manuals it very confusing what is an interface, port (I do not mean port number), and whether you refer to it as logical or physical?

Namely, what /which are ports, interfaces, what devices mean in vlan config? Which ones you refer to as physical and which ones as logical/virtual? I would think that those on the router front panel are only physical ports and the rest would be logical/virtual.
On the devices front panel (ports?) are labeled LAN 1 - 4 and WAN - how those LANs are related to eth0 or eth1 and to the LAN in the config?

LAN in the config seems to be a related to the system’s IP and VLAN1, the WAN seems to be related to VLAN2. None of them can be changed, so how can I setup this router if my LAN IP is on a different subnet and how can I direct/route WAN (or 5G Mobile internet access ) via one of the LAN ports to another router’s WAN port, without effecting other ports?
How can I separate additional networks/subnets from WAN when I use RUTX50 as an access point for extended WiFi from existing networks?

What name do you use for eth0 and subsequent eth0.1 or eth.0.20? What is the role of them in RUTX50 as there are only two eth0 and eth1? So far I did not see eth1 in any config option.
To which LAN port/interface those are related to or how they can be associated with them, practically how to use them? How they are related to the VLAN config?

Why any new LAN created defaults to a Bridge on eth0?

What does it mean by ‘Device name’ in the VLAN config? I would think that it is to create additional VLANs not to add any name of a physical device? VLAN is not a device, or do I miss on something here?

To be honest, I followed your manuals but there is nothing showing any relation between different parts of the config and it lacks explanation of the terms.
I’m finding it very confusing and struggle to make it work.

I would be happy to have a chat with someone and have my questions answered.


Welcome to Teltonika Networks Crowd Support Forum!

LAN 1-4 is by default in eth0 interface while WAN interface is by default in eth1 interface as shown below:

If you want to change the LAN IP of the router, you can simply go to Network → LAN → click the pencil icon → change settings to desired IP. To separate additional networks from WAN, you can add another Wireless interface which will connect you to a guest network. More information HERE.

By default, eth0 is related to LAN 1-4 of RUTX50. Once you create a VLAN and you want to add a specific interface to that VLAN, then it needs to be added through Physical settings. For example, I want to integrate LAN 2 to VLAN10. To do that, go to Network → VLAN → Port Based → click Add. Type 10 as VLAN ID → change LAN 2 to untagged VLAN10.

Then go to LAN → Input an Interface name then Add. Input a new range of IP → Enable DHCP → Under Physical settings, change interface to eth0.10 pertaining to VLAN 10 → Lastly, click Save and Apply.

As eth0 is a dedicated VLAN for any created LAN interface, it will be bridged to it by default. Once you created a different VLAN, then you can do a configuration similar to above.

Device Name is required in configuration simply for easier tunnel management.

Hope this clarifies your doubt.


Thank you Janmiguel

Most of it is understandable however. I think the best will be if I explain what I want to do.

  1. The 5G mobile Internet access passed to the USG WAN port, via set of interconnected switches and dedicated VLAN to span LAN 1 port of the RUTX50 and WAN port of USG 4 Pro.

When I used default config and plugged it in, I got LAN IP from the RUTX on the USG. So I switched to bridge Mobile 1 WAN and before I knew, my laptop which was connected on the LAN 2 received an IP from the 5G. I tried to release it on the laptop but USG got back to the LAN IP. What I the best way to make sure I will have 5G mobile IP n the router?

  1. I want to extend an existing 3 WiFi networks and to be broadcasted instead of the native RUTX50. Each of our WiFi networks functions on a separate VLAN and IP range. For this I think I have created three LAN networks, 3 VLANs, and a trunk port, on a LAN 4 by tagging each one there. On LAN networks I configured DHCP relay. As this have to be separate from Mobile WAN, which I put on LAN1, was Untagged on vlan 1. But so far any attempt to make it work failed. Definitely I’m doing something wrong because I could not get IP assigned to the device attempting to connect to any of the WiFi net.

  2. I need to change default LAN to but when done so, I cannot access internet anymore. I cannot change default .1 in the address to any other number on the last oktet because I loose the internet access
    I can’t leave default IP because it clashes with USG default network. There is no option for a default gateway to be configured, unless for relay dhcp. DHCP runs on the USG for those WiFi nets and it is a gateway with primary WAN on it.

Any suggestions very much welcome.

When configuring Bridge Mode for RUTX50, make sure that the WAN MAC Address of USG similar to this.


Once you created a VLAN and assign it to a specific port, next thing to do is attach that VLAN to the Wi-Fi. To this, go to Wireless → SSIDs → click the pencil icon of the desired Wi-Fi → Under Network, choose the interface (VLAN) that you want to connect.

Once you change the LAN IP of RUTX50 to, can you go to System → Maintenance → Troubleshoot → Then try to ping any DNS Server like or Let me know the results.


Hi Janmiguel.

Yes, MAC is assigned on the Mobile 1 interface, and it is set to Bridge mode.

LAN IP changed to, DHCP enabled, Untagged on LAN1 port and connected to WAN2 port of USG.
If LAN is in Bridge mode on RUTX50, the USG gets LANs IP, if Bridge is off on LAN, there is no IP at all on the USG WAN2 port. I would expect the IP from Mobile 1 in this case.

The moment IP is changed on the LAN, WiFi client does not get IP, and this is regardless if I try default one or an added and configured with additional VLAN. So I loose the internet access. I tried that first by only changing IP and having no other config or connections. When I revert to the default IP, guess what, internet is back.

Can this be an isseu wit the firmware?


Could you confirm that the MAC Address that has been configured in Mobile 1 Interfaces is the Ethernet WAN2 MAC Address of USG?


Yes, that is correct.


For further troubleshooting, can you try to configure Bridge Mode with your PC. You can refer to the same topic HERE.


Hi Janmiguel,

I’m afraid this is not even close to the solution. I have numerous PCs, laptops, client mobile devices and other network devices which need internet access, so configuring a mac address of a single PC does not make any sense.
My intention was to replace the USG with RUTX50 for its dual SIM as I can get decent fibre or any sensible wired internet connection, but I have great doubts that it can be done.

I have Three mobile router on the net and it connects to the WAN 1 port of the USG and the only thing I had to do, was to put it into a Bridge mode for it to work. I have public IP on the USG port and whole network has access to the Internet, not just a single PC. The WAN ports are set to the Balance mode.

I expected from RUTX50 to do exactly the same for the Internet access, set its Mobile or WAN interface into the Bridge mode for it to pass its public IP to the WAN interface of the USG router. But it doesn’t do that.

Also, I do not understand why LAN interface when in Bridge mode supplies LAN IP, while in the Wired or non-Bridge mode, simply does not work at all. I mean, no IP gets to the USG’s WAN port. I have LAN 1 port set in its default Untagged status for VLAN 1 and all other are off.

And this is only one issue I can’t resolve it.
I mentioned extending WiFi networks and for this I configured extra VLANs, WiFi interfaces, networks and set DHCP into relay mode, which also did not worked. I mean no WiFi client was getting IP.
Why changing IP range on the LAN interface, from its default to any other, makes internet access impossible?

I read all related manuals and followed it but none actually provides details about relations between different parts of the config to make it work as expected. How one affects the other and how it should be done. It feels like each part was separate issue without relation to another.
Well, if it was clear and easy to understand, I would not be asking questions here, right?

So, if I want be able to resolve those issues, I will have to look for another product which will be able to provide service with sensible configuration and the RUTX50 will have to go back to the supplier.
If you can, please provide details, step by step maybe instruction, from the start to the end. Maybe you know someone how will be able to make similar setup and what needs to be done?



Sorry for your inconvenience. As per this crowd topic, they want to configure bridge mode as well to a 3rd Party device. Instead of configuring Bridge Mode, they configured Passthrough with Disable DHCP option disabled. Then, input the device’s MAC Address. It worked for them with no drop outs.

Let me know the results.


This topic was automatically closed after 15 days. New replies are no longer allowed.