RUTX50 hiccups in video streams (YouTube and Facebook)

New out of the box, updated to latest firmware (/RUTX_R_00.07.06.10) without keeping settings. First impressie is that it is much quicker than my RUT950 which it is replacing. But when scrolling Facebook it constantly has problems with showing pictures and video’s. They do start but stop after 5 to 10 seconds. Speedtest shows download of 50mbits. The older rut950 only has 5mbits down (4G instead of 5G) but has no problem at all with streaming.
Same experience with YouTube, they start but stop after 5 to 10 seconds.
Completely unusable. Luckily it is from a webshop that accepts returns.

Just done a factory reset, just to be sure. Didn’t help; streaming is impossible.
Btw, SIM came from my RUT950 which is slow but at least works. Installed at same physical spot, same power-supply. Speed is good, according to ookla.
RUTX50 clearly has a problem.


  • back to firmware version RUTX_R_00.07.06.10
  • disable 5G, to compare with my RUT950
  • smaller MTU, 1470, 1420, 1400
  • custom APN
  • software flow offloading

Nothing really helps. Sometimes it seems to work fine for a while but never for a long time. Video streaming, and also just pictures, fail to load or stop halfway. With YouTube it can be observed it ran out of buffer. Often together with automatically lowered resolution.
Speedtests always around 50mbit down and 15 up.

Ummm - latest firmware for RUTX50 is 07.07.1 - can you try this one without “Keep Settings” and see how it goes?

RUTX50 Firmware Downloads - Teltonika Networks Wiki

Sorry, my mistake: that was the firmware the router came with.
So I upgraded to the version you mentioned, noticed the problem with streaming and downgraded to try. Didn’t help and am now again running latest and still having same problem.

Not quite correct as Teltonika is pre-installing “mass production” firmware versions (see link I provided above) and 07.07.1 is not mass production.
IF (at all) - you received the box with 07.06.10 and even that is very optimistic :wink:

Nevertheless - default settings you’ve tried obviously?
Asking as you didn’t mention so far.

Can you paste a screenshot of:


The router came with RUTX_R_00.07.06.10_WEBUI.bin Mass production FW

It is now running RUTX_R_00.07.07.1_WEBUI.bin Latest FW

Both versions were installed WITHOUT keeping settings.
Both versions have the same problem.

Can you elaborate what you mean with “same power supply” in post 2?
Asking as RUTX50 needs a 9-50 VDC power supply whereas RUT950 has a 9-30 VDC power supply.
Can you make sure your RUTX50 is not underpowered?
Even if the power supplies and their plugs look the same - but electrical specifications might be different!

The minimum of 9 volts is sufficient to have the router working. The higher voltage, for this model, is only needed when using POE. Which I’m not.
The router’s power supply is provided by a 12v battery on a boat with a charger on continuous float at about 13.6v
Power supply is not the problem. All functionality of this router is fine, except for streaming video.
Same SIM back in my older RUT950 and everything is fine.

Now that I’m remote from the router I’m connecting via ZeroTier as VPN. Same as I did with my older RUT950. But now also experiencing lots of hiccups in the connection.


Based on the information you provided, it seems like there might be a signal quality issue (The RUT950 only has 5 Mbps, and the RUTX50 only has 50 Mbps). Could you please provide a screenshot of the Status → Network → Mobile page?

Best regards,


It seems like the signal quality isn’t great. Have you tried moving the device to another spot where it’s more visible to the mobile tower? Also, you could try switching to a 4G connection, which might give you a better signal without sacrificing speed. To do this, go to Network → Mobile → General, and choose 4G as the network type.

2024-06-10-10-44-06-RUTX50 - Teltonika Networks — Mozilla Firefox

Best regards,

Thanks for the suggestions Marijus,

Moving the device to another spot won’t fix it because we are on a moving boat.
Disabling 5G was already tried as mentioned in my list of things that I tried on June 9th, 10:14am.


I apologize, I might have missed that the router is on a boat. Was the RUT950 previously capable of uninterrupted streaming, or situation was similar to the RUTX50? You mentioned that you have a “slow” SIM card. Do you know what plan it has and its capabilities? Some providers may limit streaming speeds.

Have you tried doing a file download test? For example, you can use this link: Download a file from there and check if the speed remains constant or fluctuates.

Best regards,

Maybe I need to clarify a bit better.

It is not the SIM that is slow; my older RUT950 has disappointing speed. That is why I decided to upgrade from 4G to 5G by replacing with a RUTX50. Speed is now just fine (not great, but much better).
The SIM is for 5G with fallback to 4G: see the screenshot earlier today.
The SIM is not limited for streaming speeds because there are moments it just works fine in high-res for several minutes. But than suddenly stops. Will mostly start after 10…30 seconds.
Maybe it is not just with streaming because VPN (ZeroTier from home to the boat) is also hit or miss. Also never had this with the 950; always flawless connections.

The older RUT950 doesn’t have these interruptions that the X50 now does have.
I’ve replaced like-for-like: same physical spot (also the boat), same SIM, within a timeframe of 30 minutes:

  • the 950 is slow but no interruptions
  • the X50 is fast(er) but has continuous hiccups.

Did file download test via the mentioned URL but doesn’t tell me anything; was quick.


It’s difficult to pinpoint the exact issue. You mentioned ZeroTier—could it be possible that all traffic is being routed through the ZeroTier interface? If so, that might be causing the problem. Otherwise, it’s hard to determine the issue with the device, aside from it potentially being faulty.

Best regards,

No, has nothing to do with ZeroTier because I installed that just before leaving the boat for the week. The problem was already there. I’ve invested about the whole weekend trying to figure out what the problem is with going back-and-forth between the two routers to compare and also upgrading/downgrading and going back to factory defaults, all to no avail.


Have you tried using a different SIM card from another provider, such as the one in your phone? This might give you some useful insights.

Kind regards,

Did indeed try another SIM, but is from same provider: KPN in the Netherlands. Same result.
But don’t forget that this very same SIM in the older 950 doesn’t have these interruptions/hiccups.