RUTX50 Fast connection, slow loading times

Hi, I Have a RUTX50, seems to be solid on 5G connection with 300Mb/s download and around 30Mb/s upload speeds (which is plenty fast enough for me). However I’ve noticed it sometimes takes ages to load pages, specially embedded items like photos and other things on pages… sometimes not loading at all.

The moment I connect to my iPhone 5G connection the same pages load instantly, without issue. This is across loads of websites so I don’t think it’s just a settings issue.

What could be causing it so I can make some adjustments.



Could you try running a speed test from your PC connected directly to the RUTX50 via an Ethernet cable?
In particular, it would be good to see ping, jitter and packet loss values to see if any of them could impact the connection. In case the RUTX50 is not on the latest firmware version, please update it and enable Software and Hardware flow offloading by navigating to Network → Firewall → General settings.

Best regards,

I will have to run speed test and get jitters numbers but they where very low.

I also have tried connecting via wired connection direct and made very little difference if any.

I’m on the latest firmware, so all upto date.

Only thing I’ve changed is when I updated firmware a few weeks ago, all other settings have stayed the same.

Have a decent connection to 5G.

Any other ideas?

Could it be a DNS issue?

On wifi

Sometimes, I have a similar issue with 5G. It is simply too crowded and when I use my phone on 4G it is much faster as the overloaded 5G connection.
It would be handy to have a switch that makes you able to select 4G or 4\5G

1 Like

My first thought was 5G causing issues so I changed settings to 4G/3G/Auto and it changes nothing.

It could be just EE, but it’s been going on for a few weeks now and just getting more annoying.

if possible please verify if you can change DNS Settings and set Google and to check if you will get better results with loading pages.

Sometimes visible delay might be caused by something else than simply speed of negotiated 5G/4G connection or SpeedTest values might not reveal the real issue.

If you checked your PC, OS etc. other thing, that comes to my mind, is MTU that may be smaller than 1500B and cannot be transmitted at once over Carrier Mobile 5G/4G network.

At PC you may simply run CLI and ping google dns IP but set do-not-fragment flag and size 1500 in bytes. If you will get unreachable or timeout it means that data are being fragmented (splitted to few packets) and it may affect opening pages - data are being splitted, which causes to see extra delay in WebBrowser.

In such scenario, please try to check Mobile connection at RUTX50, and set smaller MTU size manually even if your RUTX50 negotiate this parameter from your Carrier.

Kind Regards,

How do I change DNS, as there is not settings in the DNS tab.

I have given it a while to see if it improves and it’s the same, I have done your other surgestions.

As it stands I’ve had to start using my ProRouter as this is so slow. :scream:

What should the MTU be, it was empty to start with, then I tried 1500 then 1492 or whatever the common suggestion is… no improvement other than it hung in 5g connection longer.

Select the advanced tab/Network/DNS then input your DNS forwarding settings. I’m using the Cloudflare DNS. If you want to use Google DNS then input and then Save & Apply. Hope this helps. Also, try using a different web browser… Just a thought.

Hi, did what was suggested and given it a solid week to see if there was any improvements and none to report. Items connected keep saying “not connected to the internet”.

This router is clearly broken.

Is this via wirelessly connected device?

Is this in exactly the same position as the router, can you physically touch the RUTX50 with your hand when using the iPhone?

I very occasionally experience a momentary "Not connected to the Internet " message if the router has been idle for a while followed by webpages being slow to load for a few seconds, after which my connection becomes lightning fast.

My understanding is that if no one’s accessing the internet via the router for a while your 5G connection gets bumped down to 4G+ then again to 4G, after a while your provider disconnects because your connection is inactive. When you try accessing the internet from a disconnected, inactive state theirs a delay getting connected then moving up 4G, 4G+ and if required a 5G connection.

It can take an annoying few seconds!

Have a look at Status > Network > Mobile

What bands and at what bandwidths are you connected to?

Are you connected to any LTE bands at less than 20Mhz?

right now, they are all ≤20MHz on all bands.

I have also read about this behaviour, but as many devices are connected at once an none are inactive there would always be a small amount of traffic constantly happening.

I use about 1TB of data a month minimum.

So I don’t think this is the issue.

The same EE sim card type is in the router as in my phone, so shouldn’t expect different behaviour.

I’m also a business EE customer so no max speed issues.

You have the latest firmware for the router, but do you have the latest firmware installed for the modem?

Two different firmwares, both require updating separately.

Someone more knowledgeable may jump in and offer information, as my words below are just speculation and guesswork.

I think that there is nothing wrong with your router at all.

EE has a 600GB fair usage policy and “1TB a month minimum” is well over that threshold, well over when you’re going over every month! My gut feeling is that when you place a SIM into a device whatever it may be your network provider know what the device is… well it’s identifiable.

Is it possible that EE are throttling your connection when you put the SIM into the router because they have identified that when it’s in the router, you’re breaching their fair use policy. But when you place it into a different device, it’s not throttled.

Could EE be throttling the offending device, your router.

Perhaps you need two SIMS and then spread out the usage across the two over each month.

Try phoning EE and ask them if your being punished!

I don’t know if fair usage policies are a rolling 28 day policy or start / stop each calendar month

As akwe-xavante has said. I can confirm that EE has a 600GB fair usage a month if you have a business SIM card that was purchased from Scancom etc… If you have a contract with EE directly, your data allowance could be a lot less than 600GB a month. You could check for any messages from EE on your RUTX50 by following… Services/Mobile Utilities/Messages… It should give you some information from EE with regard to your re-set date for your data limit. I’m in the firm belief that there is nothing wrong with your RUTX50, and it is either a setting that’s not configured right, of something to do with the web browser you’re using. I’d start by checking any messages, and then try a different browser, or another computer if you have one that you can use.

Just to quickly reply, I have two business EE sims in the router, both with 1000GB fair useage, so thst is 2TB total.

600GB limit is for private customers, business is 1000GB per sim. Had this confirmed to me several times by EE business team as I have asked when going through to technical what I get and don’t get.

The sims do not exceed 950GB each as set.

Just thought I would let you know I have checked if I’m in breach of the fair useage and I’m not. No throttling.

To drive this home further, my 3 iPhone sims I have also in unlimited I have swapped in with same results.

Interesting, no two SIMS are the same, i have an EE Business SIM, truly unlimited! But i has a 600GB fair usage policy, but it is with Scancom rather than directly with EE.

Have you updated the modems’ firmware (not the routers’ firmware)?

Hope someone more knowledgeable jumps in and helps you further.

I can’t speak for other company’s selling as 3rd party, but directly with EE is 1000GB, they don’t advertise this and I’m sure it’s subject to change, but I have many sims with them and I verify every-time it’s still 1000GB for business usage.

I share the load between sims and both are over 600GB per month, and have been like that for over 12 months rolling, so if I was going to be hit with fair useage I would have been.

No SMS received from EE either to say I have gone over.

Could this be because you’re using two identical EE SIMS and a problem with the IMSI, IMEI & ICCID identification info.

Two SIMS with the same carrier being used by the same Modem IMEI registered number, and your usage IS NOT being fairly shared across the two SIMS.

May be better off using two different carriers, however some are experiencing SIM switching issues where one of the SIMS is an EE SIM, Teltonika are aware and i’m sure they are working on a fix.

A wild stab in the dark!