RUTX50 failed to resolve host name

I have an RUTX50, was working ok up to 3-4 weeks ago. Suddenly Mobile lost connection… states FAILED TO RESOLVE HOST NAME…tried APN manual/auto, simcard runs perfectly on other devices (Ipad/Iphone/Android, tested all)…
How come these teltonika cannot get automatic APN like other mobile modems???
Need assistance…

Firmware version: RUTX_R_00.07.06.1
Firmware build date: 2024-01-02 09:57:45
Internal modem firmware version: RG501QEUAAR12A08M4G_04.200.04.200
Kernel version: 5.10.199

As a first step, can you upgrade to the latest firmware version 07.07.1 and then see how it goes?

RUTX50 Firmware Downloads - Teltonika Networks Wiki

Done now last upgrade available installed, same outcome. Also tried another simcard from other operator same result…

Okay.
As you probably enabled “keep settings” when you upgraded, can you now reset to factory defaults?
This will help to properly restore “Auto-APN” settings - saying this as Auto-APN usually works like a charm.

Will try, reverting…thanks!

Done full reset, nothing… garbage mobile modem. I run the same card on 4g tplink modem, automatically runs without any setting at all… how come this crap cannot get connected out of the sudden???

This is indeed weird.
Can you post a screenshot of:

image

image


The settings of your mob1s1a1 interface





And of course the eventlog.


Have you tried already: 4G only and IPv4 only?

Attached as much as i can get with one.
Tried again ipv4 and 4g only.
Apn selected automatically is correct…
Very dissapoonted…








What about those “SIM not inserted” messages?
Looks like something’s wrong there?
Are you sure you inserted it correctly?
Can you blow into the slot to make sure there’s no dust but also clean the connectors of the SIM card (= the metal part) to make sure there’s no fat from human skin on there?




Another option would be to put the SIM into a mobile phone, turn off PIN protection completely and put it back to your router.
Basically try the SIM without PIN protection.

This sim state error was back on 29/04 when the issue was arisen…
I was exchanging the sim from pos. 1 to 2 and vise versa, before changing the default sim acc’ly… so that is why the error…

Sim card is cleaned and always inserted correctly as the modem always has Mobile signal from operator (3 bars)… and it also automatically gets correct APN after the installation of latest firmware…

Will try without PIN again and revert…

Thank again for your assistance.

Hello again, tried everything, with pin and without.
Manual Apn, auto Apn, reset, EVERYTHING.
Sim card is inserted properly, cleaned, all appear ro be ok. But still nothing, no service.
Sim card tested again in various mobile phones, works perfectly with 5g insternet…
I am starting to get angry…
Need further assistance.

@Marijus
Anything you can help with?

Some further assistance would be highly appreciated.
Thank you

Can you pls assist further?

I am still struggling with this very expensive equipment, can someone from Teltonika assist?
This is my 3rd reminder…

I was reading through the whole thread again and one thing that comes up my mind:
Did you try the Bootloader Menu method to simply put the latest firmware on the box again?

RUTX50 Device Recovery Options - Teltonika Networks Wiki

Can you do that and we’ll see if the modem becomes alive again?

Hello,

Could you please confirm if you have tried completing a faactory reset or accessing the bootloader menu? Thank you.

Best Regards,

Unfortunately, i am away on a business trip now. Will be back and try this after 01/06. Sorry for that.