RUTX50 does not use 5G when set to Auto

RUTX50 set to 4G + 5G uses LTE only unless band selection is manually setup. Is this just a function of my current ISP or is there another reason why when set to Auto the 5G band is not used?


Usually this type of behavior is caused by a stronger cell being available nearby, and that cell not having 5G capabilities. This can be mitigated by either locking to the bands only available in the cell with 5G capability, or for more advanced users, performing cell lock. Cell lock has an added benefit of not “losing” any bands during the carrier aggregation.
For example, let’s say Cell A has LTE bands B1 + B3 + B7 + n78 5G, and Cell B has bands B3 + B20. Since Cell B is closer and has a better signal, the router will connect to it. However, it won’t have 5G access. With the first (band locking) option, you could only allow router to connect to B1 and B7. This way it will need to connect to Cell A, as these bands are not available on Cell B. You will have n78 available in this configuration, along with B1 and B7.
However, when using cell locking, you can lock onto B3 of the Cell A using it’s cell ID. This way the router will aggregate all bands available on Cell A, thus increasing the throughput. It should be noted, that cell locking is not an official feature, and can cause stability issues, thus it is not recommended to use this in environments where stability is important or no physical access to the device is available.
This procedure has been described in the greater detail in this thread: RUTX50 - Locking 5G-NSA CA bands manually
Additionally, if your device still reports the connection as 5G (NSA), then it should be noted, that the current RutOS release has a bug, where only 3 bands are displayed. The rest of them can be seen by logging into the CLI, and running the command gsmctl -A 'AT+QCAINFO'. If 5G band is available in the list, please disregard the previous comments about cell locking.
Hope this helps!

Best regards,

Thanks for the reply! I will look into how to connect via CLI later (I’ve never tried it) and see if when on Auto a 5G band is reported.

Note that if I set the device to use 5G only it does not connect to the network at all.

CLI using the command you offered displayed the following

Network type: 4G + 5G
Band selection: Auto
root@Teltonika-RUTX50:~# gsmctl -A ‘AT+QCAINFO’
+QCAINFO: “PCC”,300,100,“LTE BAND 1”,1,93,-97,-9,-69,12
+QCAINFO: “SCC”,1598,100,“LTE BAND 3”,1,93,-100,-10,-79,0,0,-,-
+QCAINFO: “SCC”,6200,50,“LTE BAND 20”,1,93,-85,-12,-63,1,0,-,-
+QCAINFO: “SCC”,2850,100,“LTE BAND 7”,1,93,-110,-10,-91,7,0,-,-

Network type: 4G + 5G
Band selection: LTE B20, 5G 28 & 78
root@Teltonika-RUTX50:~# gsmctl -A ‘AT+QCAINFO’
+QCAINFO: “PCC”,6200,50,“LTE BAND 20”,1,162,-82,-11,-54,-2
+QCAINFO: “SCC”,650688,12,“NR5G BAND 78”,93

It seems like it is the case where the device connects to a cell without 5G (note the different cell ID on B20 with and without band locking). So cell/band locking would be the best option here.

This is because most carriers are currently utilizing 5G NSA (Non-Standalone) setup, which only uses 5G baseband, but everything else is handled by 4G. This means that the device needs to connect to 4G first, and only then can it connect to a 5G cell.
Eventually, the carriers will implement a 5G core, and then you will be able to connect to the 5G SA (Standalone) network. Standalone 5G will use it’s own core, thus 4G will no longer be needed. Once standalone network is available you should see the low latency that is associated with 5G networks.

Best regards,

So just to clarify, the command to lock onto B20 for this particular area would look like so:
gsmctl -A 'AT+QNWLOCK="common/4g",1,6200,162'
Make sure to remove any band lock before applying the command. Additionally, every time the modem restarts, the cell lock will be lost, thus a script could be utilized as in the previously linked thread.

I appreciate the help. I would probably be able to get the CLI and script at boot working if I read through the linked post in detail and tried it out but it might be a bit beyond my tech capabilites and the RUTX50 is being used as a domestic connection (so any interruptions while I tried such methods would for sure lead to complaints from some angry teenagers :rofl:) so I think I will just rather wait until the ISP rolls out 5G SA (Standalone ) network

1 Like

I tried the SIM from a 5G plan on another ISP here and when on Auto 5G appeared - also on 5G NSA.

The ISP for the main SIM said to use manual band selection which I did but it seemed to affect connection performance so I switched it back to Auto. I was about to call them up and ask why only LTE bands appear when on Auto and then I remembered the status screen currently shows 3 bands only so I ran the CLI you offered and it showed 5G, so on Auto so it seems I am actually getting 5G then.


Correct, you are using the band n78, which should deliver quite good speeds. It also helps that the channel bandwidth is 20MHz (RUTX50 maximum) on 3 out of 4 LTE bands, so if the results are from the new carrier, I’d recommend sticking with them.

Best regards,

When I noted “I tried the SIM from a 5G plan on another ISP” I meant the SIM from my work phone since it’s on another network. The results pictured above were from the regular SIM in the RUTX50 which is a 400/100 home internet SIM, not important but to be clear.

Both offer 5G NSA so they are not true 5G yet are they? And the apparent speeds offered by our home internet SIM seem to be inconsistent. Our teenage son plays online multiplater games and is consistently complaining about the quality of the connection. I asked him to record some speedtest results (and yes I know the RUTX50 software includes a speedtest fuction) which I am including here.

When I contacted the ISP of the home internet SIM they had suggested manually assigning 4 & 5G bands but which appeared to affect performance (on the right in the image) so I switched back to Auto which shows only 4G on the standard UX (since only 3 bands can appear) but does show 5G N78 when running a CLI check.

Our son commments on the ping rate being reported in-game and then checks it using speedtest so I’m sharing the results here. I’m not expecting miracles since at the end of the day it is still a mobile internet connection. BUT it isn’t true 5G yet, if that would make a difference?

The issue most likely comes from an overloaded cell. Perhaps the ping times increase at the evening around 6-9 PM? If that is the case, there is not much else to do from the RUTX50, as the limitation is from the carrier side (other than changing the bands manually).
Once 5G SA rolls out, the huge latency issues should be reduced, as a true 5G cell with 5G core can handle many more simultaneous clients.
One more thing I could suggest, is once the latency issues start once again, try running this command without locking the bands:
gsmctl -A 'AT+QNWLOCK="common/4g",1,6200,93'
This will make the B20 cell the primary, which should keep the similar speeds, and may reduce the latency. If it does not help, the cell lock can be removed by rebooting the internal modem in the Status → Network → Mobile menu.

Best regards,

Okay, many thanks for the help with explaining things and the tips!

root@Teltonika-RUTX50:~# gsmctl -A ‘AT+QCAINFO’
+QCAINFO: “PCC”,300,100,“LTE BAND 1”,1,93,-103,-13,-68,7
+QCAINFO: “SCC”,1598,100,“LTE BAND 3”,1,93,-95,-8,-77,1,0,-,-
+QCAINFO: “SCC”,6200,50,“LTE BAND 20”,1,93,-86,-15,-61,1,0,-,-
+QCAINFO: “SCC”,2850,100,“LTE BAND 7”,1,93,-105,-9,-86,6,0,-,-
+QCAINFO: “SCC”,650688,12,“NR5G BAND 78”,93

root@Teltonika-RUTX50:~# gsmctl -A ‘AT+QNWLOCK=“common/4g”,1,6200,93’

root@Teltonika-RUTX50:~# gsmctl -A ‘AT+QCAINFO’
+QCAINFO: “PCC”,6200,50,“LTE BAND 20”,1,93,-84,-10,-54,3

root@Teltonika-RUTX50:~# gsmctl -A ‘AT+QCAINFO’
(Running again just to check it and assuming 5G-78 appears as its on the same cell as LTE-B20)
+QCAINFO: “PCC”,6200,50,“LTE BAND 20”,1,93,-84,-11,-57,2
+QCAINFO: “SCC”,650688,12,“NR5G BAND 78”,93

I have run the CLI as suggested and will be testing the results. I am assuming your suggestion of running the command to make the B20 cell the primary was due to the fact that the ISP suggested to manually assign it? If running the command to make the B20 cell the primary helps is there a way to make it so that it runs automatically at reboot?

Also, minor thing, I noticed that in using RESTART CONNECTION did not appear to remove the lock so that the 5 bands from Auto mode would appear again, or at least so it appeared, so I had to fully reboot the device instead.


Yes, using this command has an advantage of using the B20 that was suggested by the ISP, but also aggregating all the other bands as secondary bands. In theory this should leave you with the latency of the carrier suggested settings, but similar throughput as in Auto mode.

Another user has written a script to constantly check the cell lock status that is available here: RUTX50 - Locking 5G-NSA CA bands manually - #9 by bifteki. The values will need to be adjusted according to the particular band you are connected to.
Please report if switching the primary band helped!

Best regards,

Ok thanks again!

I noted from the the post with bifteki that you noted the following:

However, the RUTX50 modem does not officially support cell locking, and locking to a cell is not advisable, as the carrier may need to move your device to a less congested cell, and this will simply not be possible if you are locked onto a specific PCI.

So the script you offered below is not locking to a cell but attempting to lock to LTE B20 when available or what exactly is the logic behind it?

try running this command without locking the bands:
gsmctl -A 'AT+QNWLOCK="common/4g",1,6200,93'
This will make the B20 cell the primary, which should keep the similar speeds, and may reduce the latency.

And based on the CLI above
gsmctl -A 'AT+QNWLOCK="common/4g",1,6200,93'

and bifteki’s script in my example it would it be as follows?

gsmctl -A 'AT+QNWLOCK="common/4g",1,6200,93' 
sleep 5

while true
OUTPUT=$(gsmctl -A 'AT+QNWLOCK="common/4g"')
if [[ $OUTPUT != '+QNWLOCK: "common/4g",1,6200,93' ]]; then
gsmctl -A 'AT+QNWLOCK="common/4g",1,6200,93'
sleep 3600
) &

exit 0

What exactly is this script doing in terms of affecting the 4G bands being used?
And is it something that should be run at device boot and if so how do I accomlish that?
And if one adds a script to run at boot how does one then stop it from running at boot in necessary?

Sorry for what may appear like obvious questions - I am familiar with e.g. Linux console commands, or at least the basics but the above is new to me.

I have tried using the example CLI command and results have been inconsistent
gsmctl -A ‘AT+QNWLOCK=“common/4g”,1,6200,93’

In that case, it seems like the issue here is due to an overloaded cell, and there aren’t many options left from the RUTX50 side.
If the connection was more stable on Auto, it is most likely the best option here.

Best regards,

I am still testing things. I started the device on Auto this morning and then ran your CLI and have been testing it for the last 6-7 hours.

Im also from Sweden with Telenor Surf Sim unlimited speed 5G.

I have similar issues but my main concern that after a few days 5G does not work at all. It seems to lock to 4G even after restarting the modem and the router. When this happens it wont return to 5G until i toggle between Auto and 4G+5G setting, then 5G works again. Software related?

5G works in both settings AUTO and 4G+5G setting.
If i choose 5G only, there is “no service”, is this 5G SA only? (I only get NSA here)

Below you can see Auto, 4G+5G and 5G settings:
root@RUTX50:~# gsmctl -A ‘AT+QCAINFO’
+QCAINFO: “PCC”,9460,50,“LTE BAND 28”,1,67,-77,-13,-45,1
+QCAINFO: “SCC”,1750,100,“LTE BAND 3”,1,19,-88,-17,-61,-1,0,-,-
+QCAINFO: “SCC”,3350,100,“LTE BAND 7”,1,211,-98,-12,-79,0,0,-,-
+QCAINFO: “SCC”,51,50,“LTE BAND 1”,1,1,-95,-14,-75,1,0,-,-
+QCAINFO: “SCC”,642048,12,“NR5G BAND 78”,690
root@RUTX50:~# gsmctl -A ‘AT+QCAINFO’
+QCAINFO: “PCC”,9460,50,“LTE BAND 28”,1,67,-76,-12,-45,0
+QCAINFO: “SCC”,1750,100,“LTE BAND 3”,1,19,-89,-16,-66,-9,0,-,-
+QCAINFO: “SCC”,3350,100,“LTE BAND 7”,1,211,-98,-13,-77,1,0,-,-
+QCAINFO: “SCC”,51,50,“LTE BAND 1”,1,1,-100,-16,-74,1,0,-,-
root@RUTX50:~# gsmctl -A ‘AT+QCAINFO’

Firmware version RUTX_R_00.07.04.5
Firmware build date 2023-07-24 16:42:15
Internal modem firmware version RG501QEUAAR12A08M4G_04.200.04.200
Kernel version 5.4.229

Appreciate if you can help.


The issue is most likely similar to other threads - your 5G signal is most likely too weak, which causes the device to not use it. Please post the output of the serving cell command when 5G is active:

gsmctl -A 'AT+QENG="servingcell"'

This will help me determine the signal strength of the n78 band to check if my theory could be the case here.

Best regards,