RUTX50 catastrophic connection speed


I am using since April this year the RUTX50 with external dual Antennas. In the beginning I had 120 MBIT.
Since weeks it is decreasing significant and now I have only ~10 MBIT.

In my room I made a test with my mobile phone and this deliver me over 50 MBIT without any separate antennas.

I upgraded the router to newest version but not improvement.

|Firmware version|RUTX_R_00.07.04.5|
|Firmware build date|2023-07-24 16:42:15|
|Internal modem firmware version|RG501QEUAAR12A08M4G_04.200.00.000|
|Kernel version|5.4.229|

I need this for my job and rely on Teltononika

I tried to upload the troubleshooting tar file … but as new User it is not allowed

I need support



The issue does not seem to be related to the RUTX50 itself, but rather the mobile operator. It is possible that when rolling out 5G the cell tower simply lacks the bandwidth, or is overloaded by the amount of users. Differences between the mobile phone and RUTX50 are a different story, as they use very different modems, and in some instances RUTX50 could excel, and in others mobile phone could get better speed.
Would it be possible to test a SIM card from another operator to check if there is any change in speed? If you decide to test this, make sure to use a SIM from an operator that uses different cell towers than the one you are using currently.
Could you also attach a screenshot of the Status → Network → Mobile page? Make sure to remove IMEI, ICCID and IMSI values.

Best regards,

I have no other SIM CARD … sorry

and now … no answer ?


Apologies for the delayed response.
With the current signal parameters I would expect a little higher speed, but not 10Mbit.
Could you also log into the CLI of the device and run the following commands:

gsmctl -A 'AT+QCAINFO'

And paste the output in the next comment. This will also provide the signal strength of the 5G band, as at the moment your device is connected to B20 which is intended for coverage, but not speed, and B3, which should provide some better download speed, but the signal parameters are quite bad.

Best regards,



+QENG: “servingcell”,“NOCONN”

+QENG: “LTE”,“FDD”,262,01,266A201,358,1300,3,5,5,520F,-97,-17,-60,9,4,150,-

+QENG: “NR5G-NSA”,262,01,598,-96,2,-12,431070,1,3,255

root@XXXXXXXX:~# gsmctl -A ‘AT+QCAINFO’

+QCAINFO: “PCC”,1300,100,“LTE BAND 3”,1,358,-97,-18,-58,-1

+QCAINFO: “SCC”,6400,50,“LTE BAND 20”,1,283,-84,-14,-60,5,0,-,-

+QCAINFO: “SCC”,431070,3,“NR5G BAND 1”,598


The 5G n1 band has very similar connection parameters to LTE. However, without a different SIM card to test, it’s hard to say that the issue is 100% within the carrier side of things.
We did not receive any reports that the speed gets lower over time, so I don’t think its hardware related issue either. I’d also suggest factory resetting the device just to make sure its not related to the configuration of the device (it might take some time for the device to settle onto a stable band).

Best regards,

I opened as well a ticket against TELEKOM and unbelievable they answered … maybe it is related to the Bandwith of the sender antenne … 5G is more and more used and it looks like it can be the bandwith … I will investigate in parallel with Telekom … thanks for the moment

Let us know how it goes!
Cell tower bandwidth limitation is the most likely here. As the 5G usage becomes more widespread, the backbone of some cell towers could become a major limitation, and in that case, no amount of additional LTE or 5G band will be of any help.

Best regards,

not sure whether it is related … but when I switch to use IP4 and IP6 … it will not more connect to %G

I received a phone call from Telekom and I will provide them today evening a lot of test connection results across the day … from router based but also from my mobile phone …

Furthermore we found out when I switch to use IP4 and IP6 … it will not more connect to 5G not more 4G

this is not normal or isn’t ??



The IP version and the network technology should not be related. Could you try leaving the device overnight with the IPv6 APN and PDP type and check if it connects to 5G?
Additionally, since Deutsche Telekom seems to support 5G SA, could you try setting the device to 5G-only and check if it connects with IPv4 and IPv6 APN?

Best regards,

Good morning

5G and IPV6 did not work over night … no chance. I switch back to IPv4 and 4G/5G … then it works but still only between 12 and 25 MBIT download …means really bad.

I tested yesterday the speed over the complete day informed TELEKOM in a phone call about it … they will evaluate and handover to a further technical team.

Any idea from your side ?

Router does not more connect to 5G … no idea why


Not sure why this could be happening, we did not have any similar reports. Today a new firmware version was released which addresses a lot of issues. Could you try updating and check if behavior is the same?

Best regards,

I think I will reset to factory settings but this I can do only over the weekend … maybe this will help to get at least 5G back … and regarding the speed I will try to continue with Telekom … I will give you feedback about it Monday
Thanks for the moment

ah yes I updated of course to the new firmware

it makes the impression since the update (where I can see differences in the Mobile / SIM Setup) it does not connect anymore to 5G …


The changes is Network → Mobile → General Settings menu were made to avoid confusion when the users selected 5G-only option and the device did not connect. Make sure 3G/4G/5G auto is selected.
Perhaps the device has connected to 5G over the weekend?
I’ll also ask you to attach a screenshot of the Status → Network → Mobile page to check what bands are being aggregated (make sure to blur IMEI, IMSI and ICCID values).

Best regards,

Here the screenshot of the page … maybe interesting to know … I am living direct at the border to Austria … not sure whether this can make it more difficult. … Furthermore it did not connect to 5G … still only 4G


It seems that the device is roaming. This could be the main issue here. This would also explain why no IPv6 connection is received.
If you have coverage from Deutsche Telekom in your area, I’d suggest disabling roaming on your device. This can be done by navigating to Network → Mobile → Network Operators, selecting the Operator selection mode to manual, and performing an operator scan. Telekom should use 26201 as their operator code, but they may have a different regional code, so make sure you only specify their operator code in the whitelist.
After that is done, and the device is no longer roaming, sheck the 5G status, as well as connection status with IPv6 APN.

Best regards,