Rutx50 and EE sim conflict

I have the same issue as others have reported here:

There is a conflict it seems with EE unlimited data sims bought via a well known UK company (also on amazon) and the rutx50. Till end of January 2024 everything was working fine. Now neither of my two EE sims connect via this router no matter how you play with the settings or how far you rollback firmwares. The router works fine with other sims and the EE sims work fine in other routers but since end of January there is some conflict with the router and the sims.
You can sporadically get things working sometimes just by scatter gunning lots of things which may even be just sim switching from sim 1 to sim 2 but then any changes, even changing the external antennae, will take you back to square one. On the latest firmware RUTX_R_00.07.06.3 i cant get things working at all any more however.

errors i get include
“Limited service is displayed when the modem is not registered on the network and is camping on an emergency cell”
“Mobile network rejection was recently detected”
“All available APNs were tried, unable to make connection to operator, try to enter custom APN or adjust mobile settings to make connection”

And Network type shows as 3G (WCDMA).

both auto apn and custom apn fail
username: eesecure
password: secure
APN: everywhere
authentication: PAP

does anyone have any solutions or has teltonika acknowledged this issue?


Hi this may be a totally different issue but I was getting similar symptoms with my EE unlimited sim and so decided to report a “slow internet” fault at my post code. Sure enough the next day I got a confirmation that there were problems with the towers in my area and that their engineers were trying to resolve it. That was a few days ago and today I got a notification that it was taking longer to fix than expected.

I’m confident that i have the same SIM from the same company, and although i can offer no help as such, i can say that i’ve no issues at all whatsoever… yet!

Doesn’t help much, but this may suggest that it may be an issue specific to where you live, perhaps as already suggested.

Could it be somehow related to this year’s 3G switch off?

Does the router initially go for a 3G service before quickly moving onto a 4G, 4G+, 4G+A then 5G. Perhaps an initial 3G connection partly fails and then somehow can’t then move on.

Maybe absolute nonsense, of course, as i know very little about these things.


The device staying on 3G and the network rejection messages may indicate that the connection issue is coming from the carrier side. Since the SIM works in other routers, could you try contacting EE to make sure no blocking is occurring on their side?
Additionally, could you upload a screenshot of the Status → Network → Mobile page with the IMSI and ICCID values blurred out?
Lastly, in the Network → Mobile → Network operators, could you try whitelisting operator codes 23430 or 23433 and check if that helps? Make sure to wait at least 5 minutes after applying the operator code.
Additionally, you mentioned that SIM Switch keeps happening, could you try disabling it and performing further tests only on a single SIM?

EDIT: If the previous steps don’t help, please log into the CLI of the device and run the following command:

gsmctl -A 'at+qscan=3'

And paste the output in the next comment. The command may take a few minutes to complete running.

Best regards,

Put this APN settings EE APN Settings Guide UK | Second-Hand Phones - Second-hand Phones Knowledge Centre | Mobile Phone News | Second Hand Phones

thank you for your reply.

“The device staying on 3G and the network rejection messages may indicate that the connection issue is coming from the carrier side”
But other routers are working fine.
“Since the SIM works in other routers, could you try contacting EE to make sure no blocking is occurring on their side?“
I bought via a well know reseller (scancom) who handle all queries, I have emailed them but so far no reply.

Screenshots are attached.
makes no difference with sim switch on or off but I was mention on past firmware (which I rolled back to) making small changes like that can change whether the sim works or not. On latest firmware nothing makes any difference.
running the cli command gives:
+QSCAN: “LTE”,234,15,2850,73,-119,-12,5,116
+QSCAN: “LTE”,234,15,6300,244,-93,-14,35,21
+QSCAN: “LTE”,234,30,6225,400,-96,-12,27,117
+QSCAN: “LTE”,234,32,6225,400,-96,-12,27,117
+QSCAN: “LTE”,234,30,522,276,-104,-14,25,114
+QSCAN: “LTE”,234,32,522,276,-104,-14,25,114
+QSCAN: “LTE”,234,10,39250,182,-106,-9,18,9
+QSCAN: “LTE”,234,10,39448,182,-107,-11,17,9
+QSCAN: “LTE”,234,10,1226,182,-108,-19,17,2
+QSCAN: “LTE”,234,10,199,177,-112,-18,12,3
+QSCAN: “LTE”,234,20,99,306,-134,-28,-8,101
+QSCAN: “LTE”,234,10,6400,271,-96,-13,28,8
+QSCAN: “LTE”,234,15,3624,418,-96,-13,-8,0
+QSCAN: “LTE”,234,15,3624,123,-99,-13,30,115
+QSCAN: “LTE”,234,10,3725,177,-108,-14,16,7
+QSCAN: “LTE”,234,15,323,178,-108,-14,-6,0
+QSCAN: “LTE”,234,15,323,166,-121,-19,3,0
+QSCAN: “LTE”,234,30,3350,359,-102,-13,27,115
+QSCAN: “LTE”,234,32,3350,359,-102,-13,27,115
+QSCAN: “LTE”,234,30,3179,359,-100,-15,29,114
+QSCAN: “LTE”,234,32,3179,359,-100,-15,29,114
+QSCAN: “LTE”,234,30,1815,359,-97,-13,31,116
+QSCAN: “LTE”,234,32,1815,359,-97,-13,31,116
+QSCAN: “LTE”,234,30,1617,359,-100,-17,28,112
+QSCAN: “LTE”,234,32,1617,359,-100,-17,28,112
+QSCAN: “LTE”,234,20,1392,293,-101,-14,25,114
+QSCAN: “LTE”,234,20,6175,314,-91,-14,35,114
+QSCAN: “LTE”,234,20,9360,405,-105,-16,22,19
+QSCAN: “NR5G”,234,15,428190,594,-109,-13,-1,0
+QSCAN: “NR5G”,234,15,628032,340,-99,-11,26,1
+QSCAN: “NR5G”,234,15,634080,981,-114,-13,10,1
+QSCAN: “NR5G”,234,30,431810,831,-102,-11,-1,0
+QSCAN: “NR5G”,234,30,646272,861,-108,-12,-1,1
+QSCAN: “NR5G”,234,30,636960,861,-101,-11,-1,1
+QSCAN: “NR5G”,234,30,529490,871,-94,-11,-1,0

unfortunately i have go through the reseller scancom for all help, ee wont deal with me direct. Still waiting for their reply.

anything is possible i guess, i dont really know why it works then it doesnt, then sporadically it can work again.

Your screenshot says you have downloaded 428GB data in the last month. Do you ever go over the 600GB fair usage limit?

If you rarely occasionally go over EE will probably not punish you, but if you exceed this limit often then they probably will.

no the data is shared over two sims with data limit in place on the router.

Just to clarify, is the issue repeatable with multiple EE SIMs, or just one?
I suggested that the operator might block the device based on the IMEI, which is the same for both SIM slots. This would explain why the SIM works on other devices.
If the operator says that everything looks good from their side, I will ask you to fill out the Contact Us form here Teltonika Networks - LTE Routers, Gateways & Modems for IoT so we can get in touch privately to troubleshoot the issue further.

Best regards,

As mentioned in my original post it happens on both my EE sims and also this issue has been reported to you before on this thread


In that thread they also said the issue started in January and they are also using UK EE sims and the same rutx50 router.

I’m one of the people that reported this with my EE sim card, also bought from Scancom. At first, I thought it was a duff sim card, but the sim worked perfect in my mobile phone. Scancom exchanged the sim card for a new one, but the issue continued with the new card. The problem started when I changed over to my other sim (Smarty - Three network) Everything worked fine, but when I swapped back to my EE sim it wouldn’t connect. No settings had been changed! I tried everything to get it to work, but had no joy. I decided to start again and re-set the RUTX50 back to factory defaults. That didn’t work either! I had completed a back-up when everything was working fine, and resorted to restore this back-up to the router. The only thing I can suggest is doing a “Firstboot” set-up on the router. My guess is that there is something in the firmware that stops the EE sim from connecting again when swapped over from one sim back to the EE sim card. The sim works fine in another mobile phone, so it must be the RUTX50 at fault here. I’ve got my EE sim working fine now, but totally afraid to swap over to the Smarty sim and back again to the EE sim card! Teltonika should investigate this in more depth as there are a number of users with the exact same problem. Go here to see the instructions for the Firstboot Device Recovery Options. Hope this helps. RUTX50 Device Recovery Options - Teltonika Networks Wiki

Did you checked APN settings? EE APN Settings Guide UK | Second-Hand Phones - Second-hand Phones Knowledge Centre | Mobile Phone News | Second Hand Phones 1

My APN settings were all set correctly for EE. Working perfect. I swapped the sim over to Smarty (Three Network) working perfect on Three. Swapped back to EE sim card, and it doesn’t connect. I checked the APN settings again and nothing had changed. It just won’t connect to the EE network if you use a second sim card and swap back again to EE.

scancom told me they checked both my sims and there is no block on them. will try the first boot later, thanks. for me even swapping the antennas over caused me to lock myself out of the sim.

Just be aware that Firstboot wipes everything! Good luck and keep us update…

i do think its a hell of a coincidence the issues are not with any old EE sim but all of us seem to have bought from scancom. i wondered if the switched from the ee platform to the bt platform which the sim shows when you do a speedcheck was maybe an issue but scancom say no settings have changed for the sim.

I have had zero issues at all with my Smarty sim (Three). You may be right about the sims from Scancom, but they work fine if you put them in a mobile phone… I never had this problem before January. Everything worked perfect.

My EE data SIM from scancom is working seamlessly in my RUTX50, so far, and when i do a speed test the test says i’m with EE Mobile. I’ve never had a reason to put the SIM into a smartphone or any other device.

I’ll back track on the speed test, If i use nperf it says EE Mobile, if i use Ookla the test says i’m with BT ! Not noticed that before.

if i use it says “EE Limited also known as BT”.