RUTX50 5G connection dropout (att. AndzejJ)


This is continuation of the 5G connection dropout on RUTX50 from old forum. The gist is that now and then 5G connection on a new RUTX50 drops out with 3 LEDs flashing “SIM not inserted” - device does not reboot by itself no matter what settings are set for autoreboot, troubleshoot file from RAM can not be generated as device is very sluggish to respond and only power cycle resets the device to operational state. Last thing suggested was to set writing troubleshot file to flash memory so it is retained after device reboot - which I did and now I have the fresh troubleshoot file to submit.

Previously I was talking to AndzejJ on the old forum.

Understand everyone must be very busy after the breach and all, but would much appreciate if someone gives me a shout on this.

Another failure of the same nature within 24 hours. Have a second troubleshoot file to submit, would appreciate a suggestion how/where to.

I have had this exact issue also . Seems to be intermitent.
Sometimes it will be solid for days though ?

Hi kimosabe,

Exactly! It can sit solid for a week and a half and then drop out 3 times in a space of 4 hours and then next day again. I talked to AndzejJ at some length about before old forum went down and we did not come up with any solution this far. Signal strengths for 5G is good, modem is set to reboot on ping and I also have a daily reboot scheduled - actually that last thing may have helped with stability a bit, but did not eliminate the issue. As router gets really sluggish after the “event” and refuses to generate troubleshoot file from RAM, troubleshoot file after restart is useless, since RAM is cleared. I have changed log file storage to flash mem for persistence on suggestion from Teltonika and now have new two troubleshoot files to submit - if they get back to me/us in this issue. AndzejJ also looked at troubleshoot file from a regular day of operation and said he could not see any issues with memory leaks or anything else that would cause router to suddenly seize. Only thing I have not tried is running router in 4G mode to see if the issue present there as well, since if I do that the speed become unacceptably low and I can’t sit at <30 Mbps for week+…

Maybe it’s operator related somehow? Wild guess… it’s an odd issue. I’m running a Telenor SIM in Sweden.

Im using a Telstra Sim in Australia
I updated to the latest stable firmware and as you said once the 3 lights are flashing the web interface becomes unresponsive.
i setup the no ping reboot action as well but seemed not to do anything
it has been stable for days now though ?
its certainly a weird issue


I too experienced this (this morning). First time it happened, but I do have the modem reboot on regular schedule (so maybe that reduces the probability). I notice that there is a new firmware update for the “internal modem” (not for the router firmware, but the internal modem) - has anyone tried that yet (I am at work, so cannot so do for a while) and do you think it will make a difference?

Same thing happening to me.

Please try updating the modem firmware. It addresses an issue with 5G n28 band connection, which could result in similar issues that you are having. Let me know if that helps.

I’m already on the latest one. What would be the next steps to troubleshoot this further?

Just to clarify, I meant internal modem, not the device itself. Could you share the firmware version your modem is currently on?

Exactly. The firmware version of the internal modem is: RG501QEUAAR12A08M4G_04.200.04.200

You could try resetting the device using the bootloader procedure, which will erase everything on the device and will reinstall all OS files. The procedure is described here: RUTXxx Firmware via The Bootloader Menu - Teltonika Networks Wiki
This will help me understand if the issue is coming from the firmware, or the corrupted configuration files.

I’ll give it a go.

Do you want me to try with the latest firmware i.e. ?

Correct. It includes some stability improvements for mobile connection.

That seems to have made it worse. Now it goes into the bad state almost immediately. I’ve rebooted it five times now to no avail. Same thing everytime.

I had to resort to using my phone to write this comment.

Is the device reachable? Does it connect to the carrier? Or does it freeze and becomes unresponsive to anything?

It freezes and becomes unresponsive.


You mentioned that you have a troubleshoot saved from the flash memory. Could you please share some of the System logs around the time when the device became slugish and the connection was lost? Please, blur any sensitive information if there is any.

Also, for the testing purposes, could you please try installing an older firmware version, for example, v7.3.4, to see if it becomes stable? You can download it from here.

Kind Regards,

As a temporary workaround, I have pinned the network type to 4G/LTE only (disabling 5G) which has made the device usable again :crossed_fingers:

Let me know if I can assist in troubleshooting this in any way so that we can get the root cause resolved.