RUTX50 - 07.06.x Firmware - GPS AVL Fail to Traccar

I got the same problem as described in closed topic It worked before flawless, after the update i got nothing in my traccar server. Checked and rechecked the parameters, but to no avail.

Maybe someone from @Teltonika (“Professional networking equipment…”) want to look into this issue? I mean, that thing costs a lot of money, so i expect to get some official help? Even a status would be helpful.



I’ve tested Traccar on RUT955 (it receives GPS data the same way as RUTX50) running 07.06.6, and everything seems to be working correctly with the following parameters:


The most important details are:

  • Traccar uses port 5027 via TCP;

  • Device identifier in Traccar is it’s IMEI found in Status → System menu.

If the provided screenshots don’t help:

  • Check if RUTX50 has GPS signal my navigating to Services → GPS → Map;

  • Provide screenshots of the AVL configuration;

Additionally, could you clarify if the device is online in Traccar, but does not update GPS data, or if it’s shown as offline?

Best regards,

I have all of these settings already configured and it doesn’t even go online in Traccar.

As stated in my post

Your screenshots are identical to the settings that worked with RUTX_R_00.07.05.4 but even with a factory reset and new firmware load of 07.06.6 putting the exact settings in - nothing comes through to the Traccar server.

GPS map in the RUTX50 shows the correct location. There is nothing in the Traccar logs.

Downgrade to 07.05.4 with same settings - works straight away and connection with IMEI and data shows in Traccar logs.

Perhaps this is an RUTX50 specific issue?

1 Like

First, let me thank you for fast reply.
Second, since this is not my first Teltonika, we own and use at least 50+ TMT250 and some 30+ other Devices from other companies with our traccar-Server, i’m very familiar with setting up devices, which ports to use, …

Its just the point: traccar does not recieve anything (!) from the RUTX50, albeit the RUTX50 has a strong signal and see 6 satellites.

I downgraded just some minutes before to RUTX_R_00.07.05.4_WEBUI and vóila, there it is. Online in traccar! Using the exact same parameters as in 07.06.6.

So i assume this is something Teltonika has to try out with a real RUTX50 and a traccar Server (or any other who understand AVL), and fix it. I did not want* to stay on this old firmware.


Edit: * added “want”

Tested RUTX50 with 07.06.6, it also connected instantly and provided GPS data:

Would it be possible to update to 07.06.6, reset the device and retest the functionality?
If that does not help, we may need to organize a remote session to try and troubleshoot the issue further.

Best regards,

Well, i’ve done this in the last days back and forth, since the first upgrade to 07.06.6. I also tried RUTX_R_00.07.06.3_WEBUI and RUTX_R_00.07.06_WEBUI from None of them worked as expected.

Before i go thru another upgrade, i want to verify we’re using the same. Please see the screenshot (this is Firmware which works), but maybe the Modem Firmware is different?



The modem firmware on you device is the latest, and is the same as the one I used to test.
The easiest method to reset the device would be to unselect the “Keep settings” flag when updating the device to the latest firmware. If that does not help, I will send you a form to fill out where we can reach out to you privately.
Thank you for your help while troubleshooting the issue.

Best regards,

Ok, i’ll try again and come back later. Thank you again for the fast support.


As expected, updated to RUTX_R_00.07.06.6_WEBUI (unchecked “Keep settings”), all new, rebooted, waited some 10 minutes > traccar log shows no connect from RUTX50.

So, please send me that form. Regards


I’ve sent you the form to fill out. Please specify the ticket ID as 4919. We will reach out to you via your email after filling out the form.

Best regards,

1 Like

Problem solved. The RUTX50 seems to try contacting my local router with IPV6, where the port 5027 was only opened for IPV4. Added IPV6 and works now.

But what i miss: The avl executable has a debug-parameter, what i could not find any documentation, what goes in there? Maybe someone can point me in the right direction?

root@RUTX50:~# avl -d > avl.debug.log
Error trying to connect to given socket
[avl_loop:320] error: Failed to make a connection to server

Anyway, thank you @Daumantas Can you inform the support team no further action is required?

This topic was automatically closed 40 hours after the last reply. New replies are no longer allowed.