Rutx11 DNS Servers on interface do not work

I know that this topic was already discussed several times in the old teltonika forum and maybe here too. Really tried to find a solution but no luck.
If I understand it correctly the DNS Server of my Rutx11 teltonika router works as a forwarder, i.e. if a client does not have a dns server explicitly defined it will contact the gateway, i.e. my router. The router than finds out on which interface (net) the client is and forwards the dns request to the first dns server defined under this interface. If this dns server does not respond it tries the next one etc. if none of them works the dns request is delegated to the wan isp dns servers.
What should I say? It does not work.
My question is: what parameters do I have to set in the dnsmasq main dns server of my rutx11 router to make everything work?


Apologies for a late reply.

It would be great if you could provide a bit more information.

What firmware is installed on your RUTX11?

Which DNS servers are currently in use, and could you provide details about your configurations?

Are the DNS issues specific to LAN clients, or the RUTX11 itself is unable to resolve hostnames?

Could you please navigate to System → Maintenance → Troubleshoot → Diagnostics section and perform nslookup? Try putting as the address and share the output here.

Also, I would recommend taking a look at the forum posts here, here, and here.

Kind Regards,


The topic above was started with my old RUTX11 firmware where I had the possibility to define dns servers in the interface section. This was the old firmware version. Meanwhile I updated to the new firmware version. Now, everything got even stranger.

New firmware version…
Firmware versionRUTX_R_00.07.05.4|
Firmware build date 2023-11-07 15:54:54
Internal modem firmware version EG06ELAR04A08M4G
Kernel version 5.10.188

The interface section now split into LAN and WAN section. If I go to LAN, I see my lan interface. I click to edit and under the tab “interfaces: LAN”, subtab “General settings” there is no possibility to enter DNS servers anymore. I suppose something changed.

Nevertheless, perhaps I should desribe my problem precisiely.
As far as I understand, a client in a network has the possibility to define its own dns servers. For exmaple, an iPhone has the possibility to definde, let’s say, as dns server for its wlan connection.
If there is no dns server specified within a client, I suppose, that the client sends the dns request to the gateway.(in our case this would be the RUTX11). Moreover I think that the RUTX11 uses dnsmasq as its dns server. If the dns request from the client reaches dnsmasq I could use dnsmasq to handle the dns request (don’t know how but this is not important for this topic).

What I am looking for is a possibility to tell dnsmasq on RUTX11 to forward the dns request from the client to my own (bind9) DNS servers. This is al I want.

In the older firmware version I really tried everything but didn’t succeed. I am pretty sure that I am missing a specific point.
Now, that I have installed the newest firmware, I would also like to know where to put my own DNS server IPs.

The nslookup result is…

Address 1:
Address 2: 2a00:1450:400d:802::200e




It seems that DNS is working on RUTX11 as it is able to resolve hostnames.

In v7.05, the interfaces were divided into LAN and WAN sections, as visible in the WebUI. This division aims for a logical separation between LAN and WAN sides. In this setup, LAN interfaces facilitate internet sharing with devices, while WAN interfaces acquire internet access.

With that in mind, you can still specify DNS servers on the WAN interfaces. This will depend on what you are using - WAN (wired WAN) or mob1s1a1 (mobile connection).

If, for some reason, you will want to add DNS servers to your LAN interface, you can still to so from the CLI/SSH (username ‘root’).

# add to a list
uci add_list network.lan.dns=''
# replace DNS list
uci set network.lan.dns=''
uci commit
/etc/init.d/network restart

However, for your specific use case, if you want to use only one DNS server (your server), I would suggest configuring opiton 6 to push your DNS server to DHCP clients. This is described in the linked posts that I have mentioned before.

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.