DNS settings for PiHole

I have a Raspberry Pi with PiHole installed and have assigned it a static IP address on the LAN from my RUTX-50.

I’ve tried and failed to configure my RUTX-50 to use this as the default DNS server.

How can I do this please?


Please, navigate to Network → Interfaces → Edit LAN interface and specify DNS servers there.

Kind Regards,

Thanks Andzej - I had tried that but I don’t see any traffic going through the PiHole.

I checked my laptop DNS wasn’t going anywhere else (it’s pointing to the RUTX-50)

Is there a way of checking where the DNS query is being routed (maybe some CLI command or some log enabling?)

Are there other rules that might be interfering with this?

The PiHole was working on my old hotspot so I’m pretty confident that the settings on that are all OK. It’s connected to the network and I can ping it and SSH into it and all that good stuff.


The DNS servers specified on the LAN interface are used to resolve hostnames. If you want to specifically push a DNS server to your DHCP clients, you can do so in the DHCP server settings. For this, go to Network → Interfaces → Edit LAN → DHCP server → Advanced options and use option ‘6’ to push your DNS server. For example:

Kind Regards,

Because I’d done various tests with DNS servers, I thought I might have accidentally made a mistake, so I did a factory reset on the RUTX-50.

Firmware is all current:

The only changes I have made from factory settings are:

  1. changed the range to one of my choosing
  2. Network => Interfaces => Static Leases, added a static lease for my PiHole
  3. Network=> Interfaces => General. Edit LAN, added PiHole’s new static IP as the DNS server.

I still have internet connection, but no queries go through PiHole.

Unfortunately that seems to break the internet connection!

I tried keeping the DNS server in Interfaces=>LAN=>General Settings, and I also tried removing it.

Both resulted in the same behaviour.

The Raspberry Pi seems to be able to connect to the internet (it’s able to update it’s block lists etc) but when I try to connect to the internet from my laptop I get an error to say the DNS record is not found.

I guess that means it’s no longer using the RUTX-50 for DNS, but there are no queries logged on the PiHole so the requests don’t appear to be going there.

I know there can be some issues with PiHole if the time settings are not correct, but I have checked both the Pi and the RUTX-50 have the same time settings.


Have you pushed the DNS server (PiHole) via DHCP option 6 as I have mentioned?

Does the PC connected to RUTX50 obtains the specified DNS server?

If you have a Window PC, try flushing and renewing IP settings:

ipconfig /release
ipconfig /flushdns
ipconfig /renew
ipconfig /all

Kind Regards,

I was working on Mac, but have connected a PC to the network (for the first time) and it also cannot find DNS entry.

I tried the commands you suggest, but they did not resolve the problem.

Media State is showing Media disconnected

Yes, I pushed the Pi as the DNS server. These are the settings


Is your LAN on network

Are you able to ping PiHole from the Router’s CLI?

Kind Regards,

LAN Settings:

Ping works from CLI (or from Terminal, and I can SSH in to the Pi)

OK - so we have a solution!

Thanks for your help Andzej - your first answer was correct.

Having done a factory reset on the Teltonika I thought I should try the same on the Raspberry Pi.

With a fresh install on the Pi everything works correctly with just the Network=>Interfaces=>Edit LAN and specify DNS server there


The problem was with the Pi and not the RUTX-50 (although I could log in to the Pi-Hole interface and everything looked OK, there must have been something wrong somewhere as it now also shows the hostname and IP address when connecting to the RUTX-50 which it didn’t before. I had to connect it via ethernet to get it to be assigned an IP.)

Anyway, I hope that helps someone in future. I had searched to find how to get a Pi-Hole to work with Teltonika and found various people who had problems, but no one had posted a solution! This one works.

This topic was automatically closed after 15 days. New replies are no longer allowed.