RUT955 FW 00.07.06.3 Event Text vs. DHCP configuration

Hello Support,

I have configured my RUT955 as follows (LAN equals to 192.168.3.1).
Menu Network>DHCP>Static Leases: The MAC address of my mobile phone 38:30:f9:mm:mm:mm together with an associated IP address 192.168.3.110 and a mobilephonename.
Menu Services>Events Reporting: Event type “New DHCP client” on “All” subtypes.
Now I connected my mobile phone to the wireless interface of RUT955. An event report was generated “Leased 192.168.3.184 IP address for client 38:30:f9:mm:mm:mm - mobilephonename”.

What is wrong?
Does the DHCP configuration not work and RUT955 leases an arbitrary IP address?
Does the DHCP configuration work but RUT955 leases an arbitrary IP address?
Does the Event Text generation not work? This question can be answered with “NO” because I verified the IP address in my mobile phone.

Thanks and BR Guenther

Hi,

This is a common issue. By default, phones do not use their static MAC address when connecting to WiFi networks. To resolve this, you should change the “MAC address type” in your WiFi connection settings from “Randomized MAC” to “Phone MAC.” This should be sufficient. To confirm, you can check if your assigned IPs are in the DHCP lease range, as this could also cause issues.

000076

Best regards,

Marijus

Hello Marijus, thank you very much for your support.

I have an older mobile phone that still works with the hardware MAC address (no MAC masquerade). I have checked this; in my home network my mobile phone connects with this hardware MAC address; I also set up an IP-MAC binding in my home network, and it works correctly with this MAC address.

Now, for testing purposes, I deleted the entry in the RUT955 under the Network>DHCP menu, entered it again and then rebooted. Registering my mobile phone again on the RUT955 resulted in the same IP address (192.168.3.184 instead of 192.164.3.110) under DHCP Leases in the Status>Network>LAN menu. And now comes the strange thing. I have configured other devices in the RUT955 with IP-MAC binding and they work correctly.

In the next step, I configured the IP address 192.164.3.117 instead of the IP address 192.164.3.110 and rebooted again. The highlight: the IP address 192.168.3.184 is assigned again.

This leads to the conclusion that the MAC address of my mobile phone and the IP address 192.168.3.184 are somehow in a relationship, means the problem is probably induced by the MAC address itself.

Can you please check this in R&D?

Thank you and best regards Guenther

Hello,

I’ve tried various scenarios with static DHCP, but I couldn’t replicate the issue. Could you please share a screenshot of the DHCP setup in the WebUI? Additionally, to ensure accuracy, could you SSH into your router and take a screenshot of the configuration in the host section of /etc/config/dhcp? It should resemble the example provided.

000091

This will help us determine if the rule is being saved correctly.

Thanks,

Marijus

Good morning Marijus, thanks for your answer. I’m a novice in using SSH interface. I tried the command “ssh ”. Then I was asked for password. First I tried the one I’m using in WebUI; it failed. Then I tried “admin123”, it failed again. Then I tried “admin01”; it failed. Can you please give me a step by step description what to enter. What do you mean with “host section of /etc/config/dhcp?”. Sorry. Thanks a lot, BR Guenther

Hi,

SSH to device using this command in CMD: ssh root@192.168.1.1 (IP address should be your router’s one)

You’ll be prompted to enter password. Keep in mind that it is case sensitive. And it would be same password for your WebUI access.

After you are successfully logged in, enter this command: cat /etc/config/dhcp

And copy or screenshot output.

It worked, thanks. How can I leave the session?

Just type exit or close CMD window.

Well, Marijus, it’s interesting.

Screenshot from SSH
SSH_ScreenShot

Screenshot from WebUI

Screenshot of Event email (I have a bit re-arranged the default layout)

Screenshot of DHCP Leases in network status

Remember, all other MAC-IP bindings work correctly.

I’m looking forward to the result of your analysis.
Thanks in advance and BR Guenther

Hi,

Maybe IP adress is already leased to another device? Can you check In Status → Network → LAN, if 192.168.3.117 is already leased?

Hi,
I re-booted the device to get rid of all leases. Only my computer is leased correctly with IP 192.168.3.113.

Then I connected my mobile phone again. Result is the same: IP 192.168.3.184 is leased and reported by event email.

Hi,

You can try restarting these services via SSH:

  • /etc/init.d/dnsmasq restart
  • /etc/init.d/network restart

Can you set static lease for other devices? Laptop for example?

Concerning restart:
I switch off the router every evening, and the other morning, as today, the problem is persistent.
I think that is sufficient for the services.

Concerning other static leases:
In the last screenshot I updated two messages ago, you can see the correct static lease of my Windows tablet. Did you get this update? I added it later.
I tried a few other static MAC-IP bindings and they all work fine.

Hello Marijus,
are there any new findings? The issues will close soon!
Thanks and BR Guenther

I’m looking forward to the result of your analysis.

Hi,

I’ve been unable to reproduce the issue, even with different RUT955 units and various mobile phones. Could you please take screenshots of your settings in:

  • Status → Network → LAN
  • Network → DHCP → Static Lease

Best regards,

Marijus

Hello Marijus,
at the request of your colleague snopcyzee, I took another look at the matter.

The latest status was the configuration that I had determined via SSH config host (IP=*.117). You can find the screenshot above.

I just connected my mobile phone to the router and received an event message via email that showed the correct IP address *.117.

Now I thought: well, the error has disappeared :=)).

Full of hope, I then reconfigured the router for my mobile phone to the originally desired IP address *.110 and rebooted the router to get rid of all leases.

Menu Network>DHCP

I logged into the router with my mobile phone and lo and behold, in the DHCP leases I could now see the IP address *.117, i.e. the old configuration.

Menu Status>Network>LAN

And the event text also showed the same assignment *.117.

That’s more than strange, isn’t it?

At this point, I would argue that the firmware is not exhibiting stable behavior.

What do we do if the issue is closed in a few hours?
Thanks and many greetings, Guenther

Hello Marijus,
thanks for this very practical extension of issue life time.
So I can add another screenshot of my latest configuration.
SSH
I hope you now can asses that there is something wrong with the Firmware!
Thanks and BR Guenther

Hello,

It is very mysterious issue why the system is displaying the address *.117 instead of the configured *.110. I attempted to recreate the problem without success. It seems troubleshoot files will be needed to investigate further. However, due to the private information involved, please reach out to us directly for assistance. Visit https://teltonika-networks.com/ and use the “Contact us” section to get in touch. We’ll be happy to help.

Best regards,

Marijus