RUT955 FW 00.07.06.3 Event Text vs. DHCP configuration

Good morning Marijus,
thanks for your answer.
Which steps shall I perform in advance to generating the troubleshoot file?
E.g. shall I connect my mobile phone so that the lease in question takes place?
Thanks and BR Guenther

Hi,

Make sure to assign the correct static DHCP lease and connect your mobile phone. If the mobile phone receives the wrong IP address, troubleshoot the issue and obtain a troubleshooting file from the device.

Kind regards,

Marijus

Thanks, Marijus!
In the contact I will refer to the link of this issue.
BR Guenther

Reply to keep the issue alive.

are there any new findings? The issues will close soon!.
.

Good morning snopcyzee,

Thank you very much for your reminder.

I’m sorry, my last wording was a bit misleading. Your colleague Marijus had set the issue on status “This topic will close 3 days after the last reply.” to keep it alive for further discussion. It seems to be a more complex issue that cannot be closed across the board after 15 days. So I send a reply every now and then: “Reply to keep the issue alive.” to keep this issue alive; so it wasn’t an unfriendly request for you to respond. One comment: I don’t think the system of closing issues after 15 days is customer-friendly. It would be better to treat issues that are more complicated and cannot be solved in the short term with a different restriction, e.g. “This topic will close when solved.”

But now to the topic. Marijus had said that the phenomenon I described was mysterious and that more detailed information, including privacy, was required (Troubleshoot file, Configuration file). Therefore, I should contact Teltonika directly via “Contact Us”. I did that yesterday and now I’m waiting for a response.

In order to make the results of the research available to the general public, it would be good to keep this issue alive until it is resolved (see above). The result can then be entered there.

Thank you very much and best regards Guenther

Hi @GuentherGredy ,

It seems that addressing this issue will require examining the troubleshooting files of your router. Due to the inclusion of sensitive data, we cannot perform this on this platform. I have sent you a form to the email you registered on this forum. Kindly fill it out, and we can proceed with resolving this matter through another platform.

Best regards,

Marijus

Hi @GuentherGredy,

I’ve reviewed your troubleshoot file, and the configuration appears a bit confusing and unusual. To further troubleshoot, could you disable MAC filtering for your WiFi interface, reboot the device, and attempt to connect to WiFi again?

If this doesn’t resolve the issue, please create a backup of your device configuration, save it to your computer, and then reset the device to factory settings. Configure WiFi with a static IP address for your phone and try connecting again. Please share the findings with me.

Best regards,

Marijus

Hello Marijus,
thanks for your engagement.
What do you mean with “… configuration appears a bit confusing and unusual …”.
Could you please concretize this. Is it the way I configured the router or
is it the contents of the troubleshoot file that surprises you?

Concerning the tests you asked me to perform, I did the following steps.

Test steps according to section one of your reply above:

  1. Disabled MAC filtering under menu Network>Wireless, table entry “Sonate#4”, header “Sonate#4 SSID configuration”, tab “MAC filter”, list box “MAC-Address Filter”=Disable.
  2. Rebooted the device by pressing “Reboot” in upper right corner of the WebUI.
  3. Connected my mobile phone to WiFi again.
  4. Result: Status>Network>LAN, header “DHCP Leases”, and for my mobile phone I still encountered a DHCP lease *.117 instead of *.110 as configured.
  5. Created a backup of my device configuration (index 1).
    backup-RUT955-2024-02-09_index1.tar.gz (61.7 KB)

Test steps according to section two of your reply above:

  1. Reset the device to factory defaults by using needle at the rear side of the device.

  2. Stepped through Setup Wizard (setup WiFi AP “Sonate#4”, MAC filter disabled by default, no static DHCP leases by default).

  3. Connected my mobile phone successfully.

  4. Result: Status>Network>LAN, header DHCP Leaes, besides the entry for my tablet an entry *.117 for my mobile phone.

  5. Created a backup of my device configuration (index 2).
    backup-RUT955-2024-02-09_index2.tar.gz (56.4 KB)

  6. Configured a static IP-MAC binding for my mobile phone (*.110).

  7. Disconnected my mobile phone.

  8. Rebooted to get rid of any DHCP leases.

  9. Re-connected my mobile phone.

  10. Result: Status>Network>LAN, header DHCP Leaes, besides the entry for my tablet an entry *.117 for my mobile phone.

  11. Created a backup of my device configuration (index 3).
    backup-RUT955-2024-02-09_index3.tar.gz (56.4 KB)

Strange, isn’t it?

BR Guenther

I post a reply just to keep the issue alive.

Hi,

In the system logs, it’s apparent that your other device (MS Surface) is going through the DHCP DORA handshake process, but your phone is simply requesting a specific address (192.168.3.117). This strongly indicates that the issue lies in your phone settings. Please try adjusting them and ensure that no static IP is set on the phone in Wi-fi or any other settings.

Additionally, when you tested the device with the factory-reset Teltonika router, consider configuring a static lease before connecting your device to the router. This step will eliminate any doubts about the DHCP lease.

Best regards,

Marijus

Hello Marijus,
thank you very much for your engagement!
This is really a very strange thing. It seems to be obvious, that it is caused by my mobile phone, because it is currently the only one device, which does not work.
There are two arguments for a non standard DORA process with my mobile phone:

  1. Your findings in the troubleshoot file
  2. Some other clients connect with static IP leases as configured.

Yet, there are also two arguments against a non standard DORA process with my mobile phone:

  1. It worked correctly in RUT955 versions <07.06.3
  2. DORA works correctly within my home network, there I get the configured IP lease.

In order not to burden you for a while, I would like to do more detailed tests for myself.
Is the DORA process documented within the troubleshoot file? Can I refer to this?

Thanks, Marijus, and BR Guenther

Hi,

I noticed that the DORA process in your router is working correctly for all devices except your phone. The usual process involves discovery, offer, request, and acknowledgment (ACK), and all steps should be present even after connecting not for the first time. It should look similar to this:

However, it seems that your phone always requests an IP address on its own initially. Troubleshooting becomes challenging when the issue is specific to a particular device. If you come across similar problems with other devices, please let me know.

Best regards,

Marijus

Good morning Marijus,

after my night shift yesterday, I would like to share the results of the investigations with you and the community.

But first of all, thank you very much for your patient support and all the information you gave me. I was able to learn a lot from the RUT955 and some details of network technology. And to clear up any doubts, the RUT955 works correctly!

My thanks also go to the gentleman from GNS3NETWORK, who shared a great video about the DORA process at “DORA Process in DHCP - Explained in detail - GNS3 Network”. He mentioned this abbreviated DORA process and its background; that’s when something “clicked” for me.

But now to the result.
Not only the DHCP server in the RUT955 maintains a DHCP lease time, but also the DHCP client, in this case in my mobile phone. This means that as long as my mobile phone was within the DHCP lease time, it always tried to connect to the DHCP server using a shortened DORA process, starting with a DORA Request with the stored IP address instead of a DORA Discover. And this IP address was from an “old” connection before I configured the IP-MAC binding. The other devices that I had configured with IP-MAC binding all came “from scratch” and therefore went through a complete DORA process starting with DORA Discover.
If you switch off the mobile phone or any other device once after configuration and start it again, it then goes through the complete DORA process and is correctly assigned the IP address configured in the RUT955.

For many of you this will be self-evident, but I didn’t want to withhold the information from everyone else.

We can consider the issue resolved; I’m therefore marking this answer as “solution”.

Thanks again to Marijus and best regards

Guenther

1 Like