RUT240: Use WAN-Port as 2nd LAN-Port (V07.05)

Good evening

I have a RUT240 with the latest firmware.RUT2_R 00.07.05.

Login works
SIM is set up and mobile data access is working
OpenVPN is set up and the client logs into the server.
Login via OpenVPN also works

So far so good.

There is still one problem:
In previous firmware/WebGui versions it was very easy: You just activated “Use WAN-Port as 2nd LAN-Port”.

But with 07.05 I can’t find any instructions or anything else.
How to do this correctly?

Thanks for the help



Got a similar case here. I just changed the Mode from Advanced to Basic. Then I went to Networks → LAN → Pencil Icon → Then I turn on WAN as LAN → Lastly, I clicked Save and Apply.

Hope this helps!


Seems like we had a similar question here. Please take a look and let me know if you run into any issues.

Kind Regards,

Hi @just.here2help

Thanks for the help and the information.
Yes, that really helped. Thank you very much.

But it is totally not clear to me why this switch is not also on the “advanced” version.

Another question that came up now today.
Suddenly sometimes I can’t connect to the router via openVPN.
The browser wants to connect, but at the end I get a white page.
It is a complete mystery to me why this is happening. Like the router is overloaded.

Do you also have to add a rule (port forwarding) in the firewall for access to the router itself?
Like this for example:

thanks for your Help

its good to know that you have resolved WAN_2_LAN issue.

Indeed, you are correct there is CPU saturation issue.
I also confirm that I observer hanging WebUI after upgrading to 7.05, but with 7.4.5 didn’t see such problems. It may looks like during setting up HTTP session router is breaking connection, its hard for me to say exactly.

With port-forwarding rules, it makes sense that you add it to the router, in order to have access via VPN Tunnel. Additionally, make sure you have reverse-routing in routing table for subnet you are connecting from.

I also opened up ticket for this: RUT 240 - RutOS 7.05 has very high CPU usage spiking up to 100% - #3 by Julius

Kind Regards,

Hi Robert

Do you know, where I can download older Firmweare like 7.4.5 ?

Thanks a lot for your answer

Best regards


The firmware for RUT240 can be downloaded from here. Just scroll down and you will be able to find it (under changelog, click on the firmware version):


Kind Regards,

1 Like

Hi Andrej

I have now reinstalled the whole router and reset it to 7.4.5.
Then reconfigured.
Openvpn client configured, this connects

Connecting to the server works in principle… but:

Port forwarding and so on must be set correctly, otherwise the router would not report at all.

What am I doing wrong?

Thanks, Markus


Do you get this error when accessing WebUI via OpenVPN, locally, or in both cases?

If you have OpenVPN client/server configured on RUT240, there should be no need to create port-forwarding rules to access the WebUI.

Could you please share your OpenVPN configurations, as well as routes (Status → Routes → Static → IPv4-Routes table) and firewall zones (Network → Firewall → General settings → Zones sections). Before sharing this information, make sure to hide any sensitive information, such as public IP addresses, passwords, etc.

Kind Regards,

Hi AndzejJ

Thanks for the reply.

I have this effect only via VPN. But I think, this is an effect if I also access the admin-area local.

I disconnected my notebook from the LAN-Posrt for about 3 days. Then I tried to connect from openVPN all the dys once or twice. In every case, it worked!

Here the screenshots:

Best regards, Markus

Here the screenshots:

Best regards, Markus


So if it working fine now? Or maybe the issue occurs only sometimes?

Is mobile signal good in Status → Network → Mobile? Signal recommendations can be found here.

Kind Regards,

[quote=“, post:11, topic:2360”]
Hi AndzejJ

Thanks for the reply.
The device is now on the way to the customer. In some days, I can check the function definitifely.

best Regards Markus

This topic was automatically closed after 15 days. New replies are no longer allowed.