RUT240 performance issues

At install location i get around 1-2 Mbit/s 3 bars on signal strength, sometimes bad SINR is indicated in the GUI. My phone runs 15 Mbit/s at the same location. Same provider (Sweden 3) on both devices.

Moved the unit to my home, better signal values, still getting bad dataspeed, 2.5 Mbit/s while my phone runs 172 Mbit/s.

Tried factory reset, tried the providers two APN, played around with band selections without any improvements.

The RUT240 has the latest firmware. In the systemlogg i got an entry “.usb supply vbus not found, using dummy regulator” can this be the problem? The earlier FW had problem with dataspeed och constant hangs och data dropouts so i upgraded the FW to the latest version.

Hello,

What firmware version is installed on your RUT240?

Also, what are the signal parameters in Status → Network → Mobile? Could you please share a screenshot here? Before doing so, please hide any sensitive information, such as IMSI, ICCID, Cell information, etc.

Another thing that I would like to mention is that the RUT240 will not be able to achieve the same speeds as your mobile phone. For more information, I would suggest checking these forum posts here and here.

Kind Regards,

OK, I seem to have gotten a little closer to the problem now. Connected by cable, I now get around 10Mbit/s, perfectly fine for me. The problem seems to be in the WIFI part of the router. Any suggestions? Because right now I only get 0.8Mbit/s via wifi…

Your RUT240 router exhibits slow data speeds [redacted] despite adequate signal strength. Firmware update addressed previous issues, but a system log entry suggests a USB supply issue. Verify power connectivity and consider consulting the device’s support for potential hardware concerns affecting data throughput.

Well tried turning of software ofloading which bumped up the speed some more on the wired connected but this didn’t solve the throughout issue between mobile and wifi. My best guess for now is that the Atheros AR9331chip is the culprit as it only give a advertised linkspeed of 6Mbit/s to connected devices. I will now try open wrt to rule out teltonika fw problems.

This topic was automatically closed after 15 days. New replies are no longer allowed.