RUT240 not receiving SMS messages

I have a RUT240 router that I can’t get to receive SMS text messages. I can send SMS messages without problems. I’ve upgraded to the most current firmware as of September 12 2023. Please advise, and thank you in advance!

Edit: I forgot to mention that I have tested the SIM card by using it in my personal cell phone and can receive/send SMS properly from that device. It just does not work with that SIM in the RUT240 router.

Hello,

You cannot see any SMS messages in Services → Mobile Utilities → Messages. is that correct?

If you try sending an SMS message to RUT240 with some command, do you get a response? For example, send SMS to get status (replace admin01 with your password):

admin01 status

Does turning OFF (or ON) VoLTE in Network → Mobile → General changes anything?

On the same mobile page,if you set RUT240 to 2G or 3G only, do you receive SMS messages then?

Kind Regards,

Yes, your understanding is correct. I’ve tried setting that VoLTE setting to Auto, On, and Off. Nothing makes a difference. What else should I look at?

Hello,

Does the router respond to ‘status’ command?

Have you tested with switching to 2G/3G?

Try changing the storage in Services → Mobile Utilities → Messages → Storage.

Also, access the CLI of the device (instructions here) with username ‘root’ and run the following command to see logs in real-time:

logread -f

Then, while the command is running, try sending SMS to your device.

Additionally, try reading SMS from the command line via the following command (1 is the index of the SMS message):

gsmctl -S -r 1

Kind Regards,

Thank you for your help so far.

The router does not respond to status commands. I have tried setting to 3G only, 4G only, and using auto for both VoLTE and Network Type options. For each option no SMS was received.

I changed the storage to the SIM card and this did not resolve the issue. I have changed it back to modem storage.

I connected to CLI and attempted to run the gmsctl -S -r 1 command but received the following error.
root@Teltonika-RUT240:~# gsmctl -S -r 1
[gsmctl_read_sms:68] error: ERROR: Library misuse

When I used the logread -f command and sending a new SMS, no output from the command is received.

I am still able to send SMS messages from the RUT240.

Thanks,

Marion

Hello,

What SIM card provider are you using? Also, would it be possible for you to test it with a SIM card from a different provider to see if it is related to some settings/options that your current provider uses?

When you run logread -f, could you try sending an SMS with a commad (SMS utilities) like ‘admin01 status’ ? What do the logs show then?

Could you also try reading SMS with the following command and share the output?:

ubus call gsm.modem0 read_sms '{"index":2}'

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.