RUT200 ZeroTier service not starting

I have a RUT200 with RUT2M_R_00.07.04.5 firmware

I use ZeroTier to create a VPN but after every router reboot the ZeroTier doesn’t connect

In the status page the service displays as disabled but when I go to change settings it shows as enabled

The way I get it to work is to set the port from 9993 to 9994, I then reboot the router and change the port back to 9993. Sometimes I have to restart the router again then it works

Could there be be something wrong with the ZerotTierPackage, I have the latest version Installed 1.10.1-1

Does anyone know how to resolve this?


Could you please clarify whether ZeroTier is actually down, or is it just shows that ZeroTier is ‘disabled’ in Status → Services? There is a known issue where ZeroTier shows as disabled in Status → Services, but it should work properly regardless.

Reboot the device, give the device ~1-2minutes to connect, then navigate to System → CLI and login with username ‘root’ (password is your WebUI password). When logged in, execute the following command to see if it is online (please do not share the Node ID here):

zerotier-cli info

Kind Regards,


Thank you for your reply! I have checked and the service is running but the status shows disabled. Good to know that this is a known issue and that it doesn’t mean the service is actually down. What happens to me is after a reboot its as if the router is not connecting with the zerotier server

When i go online to the zerotier website the “Last Seen” doesn’t report that the router is online however it is. If i change the port from 9993 to 9994 , reboot and change it back to 9993 then then the router connects to the zerotier webservice

In the image below it shows connected as its working fine now

What i don’t understand is why i need to fiddle with the ports before it will connect?


There should be no need to do that. I have tried to replicate this, but the device automatically connected after the reboot without any issues.

Are you sure that the delay you see on the ZeroTier website is because the device does not connect? Or maybe it shows that it is disconnected because the device was turned off and the webpage did not update in time?

As mentioned, could you please reboot the device and after 2 minutes, execute the command that I have provided from the CLI? What does the output of the command?

Kind Regards,


Thanks for your reply. I have done what you suggested and the issue is clear. The service is offline after the router was off for the night. I have switched the service off, saved, waited, and turned it back on and it still reports offline.

Any suggestions other than what I’ve done before to get it working? I will leave it in this state for as long as I can that way I might be able to test your suggestion.


If you leave it as it is, does it connect in say, 5 minutes?

Would it be possible for you to reboot the device, wait for 5 minutes, navigate to System → Administration → Troubleshoot and ‘view’ system logs? Please, hide any sensitive information, such as public IP addresses, MAC addresses, etc, and share the logs here.

Kind Regards,

Hi, It’s weird. After standing off for a night it doesn’t connect but now every time after a reboot it connects.

I don’t know, doesn’t make sense to me, Is there a way I can send you the system log privately as it is a lot of info, and not sure how I can block out any sensitive info and still provide you with what you need



If the ZeroTier would be disabled, the CLI command would return an error (missing port/not found). In your case, it seems that ZeroTier is running but it did not connect yet. It is possible that there is a connectivity issue, or it tries to connect before the device establishes internet connectivity, or maybe it takes some time to authenticate and connect.

There is no way to share files privately, thus you will need to post them here. However, there is no point in sharing the logs if the issue is not replicated, because the logs will not contain any relevant information. The logs are stored in the RAM and are erased after each reboot. Thus, if the issue reoccurs, please check the logs again before rebooting the device.

Also, make sure that the signal quality is decent in Status → Network → Mobile. For information about the recommended signal parameters, you can refer to our wiki page here.

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.