Probably nahhh.. For sure the worst router ever: RUTX50!

I bought and installed my RUTX50 somewhere end of March. I thought I spent wise money on a versatile router which is ready for the future. By now just a couple of month later I think is ready for the bin.

The router is very troublesome and unstable. Whether it is the connection with the provider (5G if you are lucky), the performance of your network :stuck_out_tongue_closed_eyes:, the functionality (too much not working properly) and just the continuous stream of flaws and failures of which you can find many reported in the community. Some of them I have not even listed (sms commands not working, double sim failure etc…).

Again a lot of issues which with the forum is sometimes not at all or very difficult to solve.
I paid too much for it and then the credit system which is also a pain and very unclear.

I doubt if Teltonika is on top of it. Having the recent breach doesn’t add to the credibility for me.

They have to step up. In the meanwhile I am considering to go back to my Huawei. For the speed and stability I can’t go wrong.

RUTX50 for sale.

1 Like

I would not wholesale trash RUTX50 as a bad router per se, it works pretty well, with caveat of “WHEN it works”. Hardware-wise it is hard to fault, interface is very decent and very extensive, however, one has to agree bugs are there and can get pretty bad. Another unfortunate side of the story is that until a dozen other users report the same issue on the forum issues do not appear to be taken too serioulsy. Maybe it is just a wrong impression and partly due to recent events at Teltonika, So I would not trash everything and just toss it in the bin - but there are issues with RUTX50 that need to be addressed/resolved. I have used Huawei, not 5G though and user interface leaves a lot to be desired, configs are limited, so I would loathe to sit on that, personally. But one can imagine frustration. In my own case, where 4G/LTE TP-Link was delivering 32 Mbps average, RUTX50 delivers 220 Mbps on average, with over 300 Mbps at night under 5G. Downside is that on occasion it just stops working - for me, once in 1.5 weeks or so, for others it seems to be much worse.

I hear what you are saying but my Huawei gave twice the speed at half the price despite the limited user interface. The forum is limited in resolving issues (despite that some are trying hard) and if you turn to Teltonika directly you will have a cold shower. I experienced.

I am now trying for 6 weeks to get it back running but with little to no result. (5-10Mbps drives me crazy). It’s actually getting worse. The more I dig the more issues I find. I have started 3 times from a factory reset but nada, nothing, zero…

The manual tells you what to switch on or off but with little explanations what it attributes or resolves.

I was thinking to put my Huawei on the wan port of the RUTX50. But that is weird. First of all I think the load sharing probably fails and secondly I do that to repair the RUTX which in fact should be just working in the first place.

Anyway headaches for 6 more weeks before I will be able switch it.

hi. it will helps to prove your point about bad performance (particulary if you are using LTE/5G network) if you provide performance metrics.
LTE Metrics
Also, it is interesting to compare RUTX performance statistics with Huawei router.

I probably have all the performance data you would like to see. I monitor this on a constant basis:

Speeds, uptime and signal quality (LTE).

I monitor network and bands:
Mind the black band which indicates a loss of connection… (The cell tower is on about 2km max).
and I monitor some additional data as in:

Signal strength doesn’t seem to be the issue. What I need to know whether I have provider issue or a router issue (the last one besides speed is already proven. Too many issues with this router. If it comes to stability the Huawei was outperforming this router by far. The RUTX50 has too many glitches. The forum is proof of that).

Very good. Now, if you put simcard from RUTX into mobile phone, what will show SpeedTest? Can you do such test with modern smartphone? Also, did you try to limit RUTX to 4G connection only, if such settings available?

@voljka For example, what is your LTE/5G performance/statistics? (RSSI, RSRP, RSRQ, SINR)
Did you change mobile settings or they on full auto?
Which server you selected in SpeedTest?
Is this server is nearest to your LTE/5G carrier or may be it even hosted by your carrier?

I take it that the first part is answered.
I didn’t change the settings with exception of 4G+5G selected.
The SpeedTest is always with the same NOS server
(ip address
and the cell tower is the nearest to my router (at 2km max). Cellmapper can confirm that as well.

A speed test by the router gives every similar outcome:

The same sim card in an iphone 12 gave me over a 100 (close to 120Mbps) Mbps with OOKLA speedtest.

Can you check MTU settings in Mobile interface (LTE)? As I discovered, by default it is 1500 bytes.
But my carrier use 1460 bytes. You can check MTU size with gsmctl -A at+qmtuinfo command from command line. If you have MTU mismatch, then I think, your router performance can be bad.


It seems to match…

And if you disable 5G completely, what will be SpeedTest results for 4G connection?

Please post a screenshot of Status → Network → Mobile with the signal strength parameters. It contains information about the secondary bands, which could be causing the issue. Make sure to hide IMEI and ICCID.
And could you try running a speedtest to a different server?

I assume you mean this one:

This is my last hour performance. By coincidence I had some connection issues as you can see and the router rebooted;

In the meanwhile I will change server for the speedtest.

I took the closest server (in distance) I could find from the list (not the provider server):

Outcome still in the category POOR.

You want a troubleshoot file? How do I send you the file directly (not publicly)?

I will do that trial but later at night. The risk of losing total connection is high and I dont want to upset the daily affairs now if there is no internet / wifi.

Did the LTE trial last night. No difference in speed. To be above 10 Mbps (either way) is already a victory.

@Daumantas You advised me a band lock to get a better performance. I doubt if it is still working correctly. Can we review this and see if it is still applicable?

Just a thought…

Have you changed the factory shipped antennas at all?

When comparing the RUTX50’s speed with the Huawei’s and your smartphones are the three tests performed in exactly the same VERY close proximity to each other? Were the tests performed in different rooms, indoors and or outdoors etc

When choosing a location within my home for my RUTX50 moving from room to room performing tests to find the best place to put it i got some very different results. I don’t blame the router, but rather the structure of the home i live in.

Can we assume that you only have one SIM that you are using in all three devices, rather than a different SIM in each.

Thank you for trying to help me. I do appreciate that a lot. The RUTX50 has 4 sma connections for external antennas. 2 of them are connected with a 5G Poynting directional antenna (latest generation which I bought at the same time as the router). The other 2 are connected with the standard donkey ears :smiley:. At the time of installation the antenna gave a big gain in performance. I directed it based on signal and I think that works fine. The frustrating thing is that suddenly I have huge speed loss without a decline in signal strength. When I swap the sim card to an iPhone speeds are very high (> 100mbps).
So far I haven’t found the reason for that…

The Huawei is in exact the same location and had the older version of the Poynting (3-4G) connected to it. Still it had a better performance.

Its a joke! If I send a postcard by mail it will be faster :joy:

Kansloze router…

I have a directional Poynting xol 24 4x4 (4 x sma connections).

Just tried to replicate what you have with disastrous results insofar as my download speed suffered dramatically.

Having got a directional antenna, you would believe that you have a connection to the mast that you are pointing it at!! This may not be the case, which would account for poor performance.

To find out which mast you are connected to… login to router, click on info icon by the words Internal Modem then make a note of the CELL ID number and or select and copy.

Hop over to and enter the CELL ID number noted or paste and click on the calculate button. Make a note of the CELL Identifier number.

Using the same website, click on Map (Top Left). Find yourself on the map. Using the menu (left) select your network provider and find the mast (CELL Identifier number) … This is the mast you are connected to, is it the mast you think you should be connected to?

If it’s outside the range (Angle of View) of your directional antenna, then this will give very poor performance.

Reconsider realigning your antenna and or changing it or disconnecting it.

Consider whether you have a cluster of masts somewhere that you can realign to. The nearest mast may not be your best mast to connect to. Think about direct line of sight and what stuff such as buildings, trees, undulations in the general landscape, large iron framed buildings and other structures such as bridges etc

Many thanks for the time and instructions.

I diligently followed them through…

First the good news: Yes following your instructions the connected cell tower is confirmed. I am connected to the tower I expected.

Now the strange news: If I use my provider (NOS) I only find just one of the bands (LTE B20) while I am connected to LTE B1 (and sometimes B20). So I selected Vodafone and then it show both bands (LTE B1 and B20). Both sharing the same eNB. And if I select MEO it also shows B1 and B20 (same tower but different eNB). None of then show 5G-NSA N28.

I don’t know if Cellmapper is up to date or that the providers use common infrastructure (most likely) and why there is no mention of any 5G network which clearly shows in my router…


Again I would not be surprised that data-roaming is happening and that I have been throttled by the providers. However the sim in a iPhone gives fantastic speedtest results… (do I have a router problem?)

Having said that. I still cannot explain why my speed was excellent for about 6 weeks and within hours suddenly marginalized to less then 10Mbps at the same tower with the same signal strength and RP/RQ/SINR? And since no improvement achieved…

Just a heads-up on speed test metrics … cell phone operators (in Portugal at least) know when the SIM is in a mobile phone vs. in ‘some other device’ and throttle back rather aggressively. I get 5~10x the speed with a 5G SIM card in my iPhone 13 Pro, than I do with the same SIM card in my RUTX50 … no fault of the router.

Also – I have noticed that with tourist season upon us (I live in Southern Portugal) that mobile phone networks are congested as hell. NOS and Vodafone are suffering the worst as they only have 5G NSA (not true 5G) and also seem to handle the bulk of the tourist traffic.

Attached is one speed test done from my RUTX50 right now … the Vodafone server is completely unreachable (as per usual lately), NOS is slow as hell (3.62 down, 2.58 up), and ONI (which I usually use for speed tests) is returning speeds about a mere 30% of what I was getting in April / May with the same setup. This router is band locked and whatnot … and I still get random afternoons / evenings with horrendous disconnects … my Home Assistant connection log looks like a dog’s breakfast :slight_smile:

It’s possible the Huawei is somehow spoofing what kind of device it is? The carrier thinks it’s a mobile phone? I don’t know, just guessing.