Internal Server Error Failed to create CGI process: Resource temporarily unavailable


The situation

I cannot access the WebUI of RUTX50. I receive this error:

“Internal Server Error
Failed to create CGI process: Resource temporarily unavailable”.

I did not configure anything new on the router in the past week. Therefore, I do not think that this is caused by any sudden changes.

The router is accessible locally and via VPN. I did some tests with both options.

  • I can ping the router.
  • I can access any other local device normally.
  • I cannot access any webpage on the internet (e.g.
  • I cannot SSH into the router (normally it works) - error message:
    " SSH did not work
    • kex_exchange_identification: read: Connection reset by peer
      Connection reset by port 22"

VPN (only routes traffic that is meant for the local network of the router)

  • I can ping the public IP of the router
  • I cannot ping the private IP of the router
  • I cannot access any other local device
  • I cannot SSH into the router

What I tried to solve the problem?

I tried to access the WebUI using a different browser (Chrome instead of Firefox).
I tried to the WebUI locally, instead of using a VPN (as mentioned above).
None of these worked (but they used to).

What solved the problem?

I removed the power cable for about 20 seconds and then plugged it back in. After this “reboot” the WebUI was accessible again.

Still I have 2 questions

(1) I would like to understand the problem. If anybody has a clue what happened, I would be grateful for any explanation or guesses. This would help me and others to deal with the problem.

(2) The problem was solved by unplugging the power cable. But what if I cannot unplug it, because I cannot get to the router. Are there any other solutions to reboot the RUTX50, although the WebUI and SSH are not working?

Thank you for your support!

Best regards
S. Lei


Sorry for late response. It’s hard to determine what caused the problem with accessing the RUTX50 WebUI. If possible, could you provide logs from the time when this issue occurred? This will assist us in analyzing the situation, although I cannot guarantee that we will definitively determine the cause of the issue.

If the RUTX50 is inaccessible or far from your location, you can utilize SMS utilities to reboot it remotely.

Best Regards,

1 Like

This topic was automatically closed after 15 days. New replies are no longer allowed.