Having issues configuring Wireguard on my Rutx50 router using 4g/5g mobile

I have a Rutx50 and i am using 4g/5g mobile as means for connection but for the life of me i cannot get an open port on it for some reason :slight_smile: i contacted the isp and he told me they do not block any ports, so i said ok i read on the net that maby i have to have a fixed ip to the router so i got a new fixed ip for my router but it dose not show on up on my router do i have to type that ip somewhere ? :slight_smile: sorry for my ignorance. but ok i have tried duckdns and i am not able to open any ports on the router, the thing i am trying to do is be able to access the router and lan to be able to control my summer house from the internet and access my folders/pictures sort of NAS i have the summer house. can someone help me configure the Rutx50 so i can access my summer home lan from my city home lan :smiley:

Hi Anton,

For a start have a look at the Wiki here and also read this forum posting.

Timelapse Admin

1 Like

Thank you for this , i will try this but i am having troubles opening ports for some reason.

Hi Anton,
I’m not using WireGuard but a static public IP address on the SIM card and a
port forward of https to a webcam behind the RUT using
Network->Firewall->Port Forwards. So that’s a completely different story.

I’ve also got to mention that I’m on RUT240 (currently running 54 of them).

Timelapse Admin

1 Like

i have tried everything for some reason i cannot get ports to open on the router, i am using mobile not wan.
every help would be appreciated.

What is the IP address of the mobile interface ? Does it start with 192.168, 172.16…31, 10 or 100.64…127 ? If so it is a private address and will not be reachable from the outside world.

Maybe you need to use a special APN for it to be activated.

About opening ports: don’t, if you don’t need to do so. Instead set wireguard=>lan to Accept/Accept/Accept in Network->Firewall->General Settings.

i have tried that but it is not working, maby i am doing it wrong , if some beautiful soul could do a youtube tutorial on how to configure wireguard on rutx50 over the internet would be very much appreciated, i am trying to connect to my rutx50 lan from home, but for the life of me i cannot figure out how to go about that, i see two ips one in mobile that starts with 100.xx.xxx.xxx/32 and then i get on myip.com 46.xxx.xxx.xxx

i think i have tried everything, even done everything from the wiki but i am just not able to connect the tunnels together.

So you have a private address and you won’t be able to reach your device from the outside world.

You may succeed if you ask your ISP for a public IP address (and probably a special APN also) and you are given one.

Another possibility would be to use IPv6, if your ISP gives a public address with a /64 prefix AND incoming ports are not blocked.

If you want to monitor only a few cameras and/or sensors the simplest solution is to use Zerotier, throughput is somewhat limited but it is easy to install / configure and looks stable enough for this purpose.

1 Like

Thank you good sir, my isp gave me static public ip but i am not sure how to assign the ip address to my mobile, i thought that should update automatically, but they gave me one that starts with 185.xx.xxx.xx
but i think they did not know that this was for mobile connection 4g 5g could that be because i have asked them about the APN and no response in couple of days. but i have seen on the net that this should not be a problem you should be able to use like duckdns to update your ip address when it changes to connect, so i do not know what the problem is, it seems to be that i just cannot connect into my router from corresponding port ? this is a provider that has a contract with another provider i am wondering that that could be the problem ?

Check if you have a udhcpc client process running on the router, something like:

11408 root      1544 S    udhcpc -p /var/run/udhcpc-qmimux0.pid -s /lib/netifd/dhcp_mobile.script -f -t 0 -i qmimux0

It should acquire this 185.x.y.z address automatically.

If it doesn’t, you can try the following:
go to Network->Interfaces->mob1s1a1 use the edit button and in General Settings set the Protocol field to static and set the IPv4 adress to the 185.x.y.z value they have given.
You will need to set the default gateway, broadcast etc fields accordingly.

1 Like

thank you, how do i go about executing that command you say udhcpc ?
i could give you RMS to my router if you want so you can take a look :slight_smile: how much would that cost me. i have just about tried everything but not what you are talking about now. if you could give me the commands to achieve that.

From a ssh or CLI console:

ps | grep udhcpc

What is the result ?

1 Like

root@RUTX50:~# ps | grep udhcpc
15963 root 1880 S grep udhcpc
18115 root 1880 S udhcpc -p /var/run/udhcpc-qmimux0.pid -s /lib/netifd/dhcp_mobile.script -f -t 0 -i qmimux0 -x hostname:

how can i buy you a beverage sir ? you have done enough so far!

You can try to set the protocol to static on mob1s1a1 as described above you might have some luck I won’t bet the farm on that however.

1 Like

have tried that, maby i am all out of luck maby this is to early to be thinking about this ? new router coming out and has to have time to fine tune maby ? but you good sir i owe you some how can i ?

if it is only to gift you and your better half dinner. to say thank you for the help.

Unless you solve your public IP address issue you best and simplest option is to use Zerotier.

1 Like

i will try more if not i will have to try NV1000 Wireless router 5G Ericsson, because https://www.reuters.com/technology/us-fcc-chair-asks-agencies-consider-restrictions-quectel-fibocom-2023-09-06/

Thank you again for all your help very much appreciated, i will try Zerotier but then i am allowing third party to access my network. and that is not what i want. but thank you again and may god bless you and your yours.