Confused by IPv6 on RUTx09 - no default route for IPv4 once IPv6 enabled

Hi

I’m using EE in the UK, on a RUTx09. I have the router interface mob1s1a1 configured with PDP type of IPv4. Everything works great, and has done so for past 3+ years.

My ISP now supports IPv6.

I have changed the PDP type to IPv4/IPv6. The connection gets established okay - IP address 2a00:23ee:2738:2984:df7:f9d6:663:d19a/64 - but I lose my IPv4 default route.

With PDP of IPv4:
root@Teltonika-RUTX09:~# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default * 0.0.0.0 U 1 0 0 qmimux0
10.10.10.0 * 255.255.255.0 U 0 0 0 br-lan
10.237.73.43 * 255.255.255.255 UH 1 0 0 qmimux0
172.26.0.0 * 255.255.0.0 U 0 0 0 ztkseyo6fz
192.168.60.0 * 255.255.255.0 U 2 0 0 br-VLAN60
root@Teltonika-RUTX09:~#

With PDP of IPv4/IPv6:
root@Teltonika-RUTX09:~# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.10.10.0 * 255.255.255.0 U 0 0 0 br-lan
172.26.0.0 * 255.255.0.0 U 0 0 0 ztkseyo6fz
192.168.60.0 * 255.255.255.0 U 2 0 0 br-VLAN60
root@Teltonika-RUTX09:~#

Am I missing something?

Firmware 7.06.3 (latest).

Many thanks.

Jim

Hello,

We’ve had a similar issue here: RMS + EE UK Connection Issue
From what I was able to find online, EE uses 464XLAT for transitional period from IPv4 to IPv6. This way of providing both addresses is not very common, thus our devices do not support it, and instead it only obtains either IPv4 or IPv6 address.
While we do not have 464XLAT implementation, it can be downloaded from opkg feeds. It should be noted, that this is not officially supported, so you may experience side-effects. Additionally, all of the configuration will need to be made using SSH/CLI.

Best regards,

Thanks Daumantas, that’s both very helpful and very sad at the same time. EE is the biggest and fastest provider in the UK, with the best coverage. If I understand correctly, I’ll be unable to use IPv6 until either a) Teltonika supports 464XLAT or b) every website on the entire planet that I want to use, and every carrier, supports IPv6. That doesn’t sound like a great way forward for me :frowning:

Jim

Hello,

On a second thought, on our devices we support a feature called Multi APN, meaning multiple data connections can be established on a single SIM card.
I will ask you to navigate to Network → WAN, create a new interface (we can call it mob1s1a1_ipv6 for simplicity), select the protocol as mobile and specify the same APN as for the original configuration, but choose IPv6 as the protocol. On the original mob1s1a1 interface, choose IPv4 as the PDP type.
If the carriers allows this, you should have two active interfaces - one with NAT IPv4 address and another with IPv6.
Let me know if this helps.

Best regards,

Hi Daumantas

Haha - that worked!!! Thank you, good lateral thinking.

My RUTx09 now gets an ipv6 address and I can ping IPv6 addresses on the internet from the router!

I can’t ping any IPv6 addresses (e.g. ipv6test.google.com) from my LAN, either by name or by IP. Is there a HOWTO guide somewhere, that explains what additional IPv6 setup might be required?

Hello,

Glad to hear that it worked!
As for LAN IPv6 connections, you’ll likely need to navigate to Network → LAN, edit the LAN zone, scroll down to the DHCP section, and under IPv6 tab change the RA and DHCPv6 services to Server mode:


This should be configured automatically unless it was changed manually. I would also suggest setting the DNS servers (not domains) to 2606:4700:4700::1111 (Cloudflare) and 2001:4860:4860::8888 (Google) in case there are any issues with the server obtained from the ISP.
If that does not help, could you check if the LAN clients obtain IPv6 addresses? On Windows this can be checked by using ipconfig command in CMD. The output should look similar to this:

Best regards,

Thansk Daumantas, thank you for sticking with me.

RA and DHCPv6 are both already set to Server. But the LAN devices are not getting an IPv6 address, even after ipconfig /renew6. Does this sound like I’ve missed something on the router, or does it sound more like a local computer issue?

Nah…I can’t get this to work at all. Even when connecting using IPv6 only, the router still gets a connection and an IP but nothing on the LAN gets an IP. So the DHCPv6 settings don’t seem to be taking effect?

If multiple devices were tested on LAN and none of them receive an IP address then it’s likely related to the configuration on the router. Just to clarify, do they not receive any IP address (even the link-local one, fe80:...) or do they not receive only the public prefix (likely starting with 2xxx:…)?
Are there any additional network configurations done on the router?

Best reagrds,

Thanks Daumantas (again). Here are the relevant configuyration pages on the router:

On a Windows PC I only see a link-local:

image

If I try to renew that address on that PC, I have tcpdump running on a Linux box on the same LAN and this is what I see:

Hope you can spot what I have done wrong :slight_smile:

Jim

From what I can tell, Windows is issuing RS messages but the router is not responding with RA. This is when connected directly from laptop to router via cable.

Hello,

I’ve sent you a form to fill out so we can get in contact privately. This way we can organize a remote session to try and troubleshoot the issue live.

Best regards,

Many thanks, I’ve completed the form.

Hello,

Could you clarified if you’ve received an email from us regarding the remote session?

Best regards,

I have, yes, I received the mail and replied to confirm the timeslot.

It seems like we are currently experiencing issues with the ticketing system, so let’s delay the remote session until the issues are resolved. I will message you privately when everything is solved.
Thank you for your patience!

Best regards,

1 Like