Zerotier bridge PLC´S behind different routers


I have a need to connect 3PLC´s behind 3 different RUT 200 routers and make them connect to each other like they where on the same LAN. I also need to access the plc´s from a PC and a Phone
I have red the article in this link ZeroTier Configuration - Teltonika Networks Wiki
It looks like I could create a bridge in the RUT 200´s and in zerotier
I tried this but can´t ping between computers behind the routers nor to the router from the zerotier computer.
Do I need to create a port forwarding in one or more of the routers ??
Anyone who can help ?

Anyone who can help ? I have got stuck.
My setup is like on the picture, and I have set it up with zerotier as a bridge. I can not ping between the two RUT 200´s nor communicate between the PLC´s


Could you post screenshots of the following information:

  • Network → LAN interfaces (remove the MAC address);

  • ZeroTier network configuration window, where the selected options could be seen;

  • Network → Firewall → General settings window where all of the zones could be seen;

This will help me identify the issue you’re facing.

Best regards,

I could only send on screen at the time for some reason



Make sure to configure Bridging as per instructions in this section of the article:
It’s a little more work to configure L2 VPN when compared to L3 which is what you currently have.
Additionally, in the firewall settings, change all of the ZeroTier chains to Accept.

Best regards,

Thanks for your help!
You mean like this.

I really tried to follow that instruction but fail to see what I am missing. Shall I keep the port forward according to that section or just follow the bridging section of the description ?

Hello again,
As I understand from the bridging section in the instruction

I shall not need to forward any port for communication between the two RUT 200 is that right ?
It also tell me to turn of DHCP in the second router which I did, but it still does not work
What more can be wrong ?


To configure bridge configuration, previous sections do not need to be followed.
I’ve tested it locally on the latest firmware and everything seems to be working fine.
The ZeroTier configuration looks the same on both routers:
On the ZeroTier portal, make sure the Auto-Assign IP range is disabled:

And bridging is enabled on both devices:

Keep in mind, that you’ll need to assign a static IP to your PLC in the same LAN range.
If this does not help, please post the screenshots of the ZeroTier portal as well.

Best regards,

Good morning, thank you so much for your help! I think I managed to get the bridge between the RUT´s to work last night! I, made a factory reset of one of the routers and started over again.

One follow up question though. Now when the bridge is working, how should I continue to access the Routers and the PLC´s from a PC or a Phone over zerotier ?
Should I make a port forward from the "first router " and create a route to via the zerotier IP of that router ?


Glad to hear that it’s working!

I haven’t tested the configuration, but you will most likely need to set a static IP on the ZeroTier interface, as it will not be assigning the IP addresses to these devices. Alternatively, you could re-enable the Auto-assignment of IP addresses in the ZeroTier portal. Make sure to select the network range to be in the bridged network range ( in your case), and disable Auto-assignment for both RUT200s:

I am not able to test this myself at the moment, but it should work.
Let me know how it goes!

Best regards,

Processing: image.png…
Something like this ? + Forwarding from the RUT´s ?

It seems like the image has not finished processing when the comment was posted, could you re-upload it?

Best regards,


Managed IPs should be removed from all of the devices, since L3 tunnel is not needed.
In the managed routes section, only the entry should be present.
But other than that, everything else looks correct.

Best regards,

I tried like that but I can´t ping the units in the network from a zerotier PC
If I connect a PC to one of the RUT´s I can reach the whole bridge but not from the outside as zerotier member That´s why I thought I need something more


IPv4 Auto-assign is still needed for the other ZeroTier clients, and the global configuration should look like so:

Only the RUT200 devices should have the Auto-assign option disabled individually:

Best regards,

Now it works just perfect! Thank you so much for all help!

1 Like