Zero Tier Low Bandwidth Mode?

We are currently carrying out initial tests with the Zerotier client on a Rutx11. It is important that the monthly traffic remains as low as possible.

Since version 1.10.3, ZeroTier offers a so-called ‘Low Bandwidth Mode’, which should significantly reduce traffic.

As far as I can see, version 1.10.1-1 is installed in the current package.

Will there be a newer version of the package in which this mode can be switched on and off?

1 Like


We’ll definitely update the package versions, but it might take some time because we need to test all implementations before updating especially VPN solutions.

Best regards,

Good news and thanks for the information. As we are currently still in the test phase, we hope to get the ‘Low Bandwidh Mode’ in time :wink:

+1 here.

At the moment I’m seeing 3-4 GB a month (!) being eaten up by ZT because the protocol is so chatty.
Real usage data goes on top.
Low Bandwidth Mode in a newer ZT version would be very very welcome.

You could try enabling the low_bandwidth mode over the CLI/SSH

  • Edit the the command vi /etc/init.d/zerotier
  • Insert the following lines somewhere at the end of setup_network() section:
json_add_object "settings"
json_add_boolean "lowBandwidthMode" 1
json_dump > "${path}/local.conf"
  • :wq to write changes to the file and exit the text editor;
  • Restart ZeroTier service with the following command:
    • /etc/init.d/zerotier restart

Check if low bandwidth mode is enabled and if it makes any difference on ZeroTier performance:

Hello Curios_user69,
thanks for the suggestion. I tested it briefly and unfortunately - as expected - couldn’t see any difference :frowning: .

According to the release notes, the feature is included from version 1.10.3 onwards. See ZeroTierOne/ at dev · zerotier/ZeroTierOne · GitHub
As mentioned above, the package for Rutx11 unfortunately only contains version 1.10.1. As I understand it, the functionality does not yet exist in it.

Thanks for testing it out @aschroeder :+1:
I was kinda thinking as well that this won’t work and hence hoping for Teltonika to upgrade ZT version soon.

This topic was automatically closed after 15 days. New replies are no longer allowed.