WiFi calling on RUTX14 not working but ok on RUT240

Upgraded router from RUT240 with working wifi, data and wifi calling to a higher performing RUTX14, and general performance is better, but wifi calling does not work properly. phones connected to the RUTX14 appear to make calls but there is no audio and the recipient sometimes gets a missed call, so it seems to be partially working - both routers are default ‘out of the box’ config. Any ideas?


Make sure you update the RUTX14 to the latest firmware. It can be downloaded here: RUTX14 Firmware Downloads - Teltonika Networks Wiki
If the issue is still present, I’ll ask you to navigate to Network → Interfaces → General, edit the mob1s1a1 (SIM1) or mob1s2a1 (SIM2) interface, and under the Advanced options set the Override MTU field to 1420.
Also, does the issue appear when calling both - a number on the same operator, and on a different one?

Best regards,

Upgraded to latest firmware (keeping config info) and unit rebooted and our devices connected automatically, and pleased to say wifi calling works fine now. However, I now can’t get in on the old admin password, and admin01 doesnt work either! - I get “device is unreachable” - do i now have to do a re-set?!


Just to clarify:

  • Are you reaching the devices WebUI via the local network?

  • Are you using WiFi or a wired connection?

  • Have you tried using a different browser?

  • What firmware version was the upgrade performed from?

Best regards,

Connected via wifi and using chrome or edge to get in on now doesn’t work
old firmware was EG12EAPAR01A09M4G - Any ideas?


Please try using a wired connection and check if the issue is still present. Factory reset would most likely address the issue.
Could you try logging into the device using SSH and check if it’s reachable? Additionally, have you tried rebooting the device?

Best regards,

reboot worked - all problems sorted thanks very much for help!

1 Like

This topic was automatically closed after 15 days. New replies are no longer allowed.