[WebUI BUG] OpenVPN server config: Can't set up Virtual Network IP Address

When trying to set the Virtual Network IP Address parameter it gets red I can’t save the changes, so I can’t enter a proper value. Very frustrating. What can I do?

Rut955 with firmware:


My apologies for the delayed response. Could you please try upgrading your device to the latest RUT9_R_00.07.06.10 firmware version? Afterward, please let me know if the issue persists.

Best Regards,

I did edit the webui config file directly through SSH and I can’t right now update the firmware of the device.

There is anything in the v7.6.10 that specifically targets this issue or it’s simply an educated guess?

While an IP address ending in .0 is perfectly legal these days some devices (and firewall policies) may think otherwise and it should therefor be avoided. When more than 8 bits are used for the host address, the last byte is allowed to end in 0 (or 255), because this not a violation of the standard.

You must also consider when the network uses only 8 bits ( for the host address, like in your case shown, then x.x.x.0 is not a valid option.

Wait, this is then the VPN server IP itself?

I though that I was setting the IP range / subnet

I double checked and the firmware version has been updated to 7.6.10 already in some moment between the first post of this thread and today, and the behaviour hasn’t changed.

Also, setting trying to set up an IP that doesn’t end in 0 it’s impossible also for the same reasons.

Also, I’m getting random problems to route outgoing traffic from LAN to the internet with this router. Problems that appear randomly on time. It’s possible that there is something wrong with the router itself?

This topic was automatically closed after 15 days. New replies are no longer allowed.