Webserver behind NAT

Hi all,

I’m using a RUT200 in a BMS system. I have a Weidmuller field bus coupler which has a webserver configuration page. As the coupler is in my local network, I use NAT for reaching it:

iptables -t nat -I PREROUTING -d -j DNAT --to-destination
iptables -t nat -I POSTROUTING -s -j SNAT --to-source

I’m able to ping the device but I’m not able to acces the configurations page. Could someone help please? Thank you


Does your LAN device has a default gateway configured?

Have you tried enabling masquerading on the LAN => WAN zone in Network → Firewall?

Could you please draw a simple topology with IP addresses marked?

Kind Regards,


Thank you for helping.

LAN device gateway is configured to
LAN => WAN masquerade is enabled. I attached a screenshot. Maybe something is wrong here ?
I attach topology screenshot also. When I’m trying to connect to device ( the page is just loading but nothing happens.

Tibor G.



Are you trying to communicate between different LANs (VLANS)?

It seems that currently you allow LAN to ZoneTest (but not WAN?), and from WAN to LAN, but not from ZoneTest to LAN. Is this intended? Could you please add other zones for testing?

If you connect your PC directly to network, are you able to reach your server without NAT?

Kind Regards,


Indeed, my zones were not coherent. I have created new zones LAN2 => WAN and WAN => LAN2.
I have also opened port 55421 on to acces port 80 on but no solution yet.
Could a backup help in order to check if something else is wrong ?

Regards, Tibor G.

This topic was automatically closed after 15 days. New replies are no longer allowed.