Vpn access - rut901


I’m trying to put in place a remote acess with a RUT901. I’ve sucessfully setup the RUT901, with a VPNhub but once I try to create “routes” the RUT901 doesn’t locate the equipments I want to acess.
If I put it manually it doesn’t work.

Here’s my actual configuration :


Equipments are in the subnet and I want to access them remotely from another internet connection.
My OPENVPN sucessfully gets into the subnet but I can’t ping the equipments or add them to the routes… (But my RUT901 is physically connected to the equipments)

Thanks in advance for your help,



  • Please let me know if you can access your RUT901 WebUI remotely via VPN hub?

  • Could you please check if LAN forwarding is enabled in the RMS VPN → VPN hubs → Routes?

  • Don’t forget to restart a hub in the RMS VPN → VPN hubs → General after adding a route.

  • Can you ping your device’s IP address from a Teltonika device?

  • Is a default gateway configured on the device you want to reach, and if so, is it pointing towards the Teltonika device?

  • Please navigate to the Network → Firewall section in the WebUI and set the forward option to Accept for the RMS zone. Also, click on edit and ensure that LAN is added in both “Allow forward to destination” and “Allow forward from source zones.”

  • Could you please try enabling masquerading on the LAN → WAN/RMS zone in WebUI Network → Firewall → General?

  • Lastly, please share the route configurations in your RMS VPN Hub → Routes tab.

If the steps I’ve suggested don’t resolve the issue, I’ll need to take a look at your configurations to help further. Please provide the necessary information, and I’ll go through your configurations to see what might be causing the issue.

Best Regards,


  • Yes i can access RUT901 WebUI remotely via the link on “d

*Lan Forwarding is enabled in the RMS VPN → VPN hubs → Routes

  • Yes, I do restart the hub after adding a route

  • When I’m locally connected in the subnet with the tektonika I can ping my device’s IP address, but I don’t see my devices on Teltonika WebUi Lan interface or on the “window ports”

*I can’t find this in Network Firewall. The only tabs are : Port Forwards / Attack Prevention / DMZ

I still have the same problems : I can’t detect my equipments…

If you want to see my configuration I’m on the account clement.grange@equans.com

Thank you for the answers!

If you don’t see certain options in your RUT901 WebUI, it’s likely that you are in Basic mode. To access the options I provided above, navigate to the right upper corner of the WebUI and change the mode from Basic to Advanced.

After that, please attempt to complete the steps I provided. Let me know how it goes. If you still encounter difficulties, I’ll send you a form to contact us privately for further assistance with all configurations.

Best Regards,

Thanks for your answers.

Here’s my firewall configuration as asked.

There’s nothing new with my problem though, still able to connect to the VPN hub but can’t see the equipments I want to connect to. When I connect to the routes I can see, I also can’t ping them.


  • Please click on the RMS zone edit (pencil icon) and make sure that LAN is added in both ‘Allow forward to destination’ and ‘Allow forward from source zones’.

  • Also, could you check if your LAN devices do not require a gateway to be set? It should be set to the RUT901 LAN IP.

  • Additionally, please ensure that your PC and RUT are on different networks. For example, if both are currently on, then change one of those networks, i.e., change RUT LAN to

Best Regards,


  • Lan is added in both “Allow forward to destination” and “Allow forward from sources zones”
  • Lan devices were set with a gateway to the RUT901 IP adress (
  • RUT is on / VPN & PC are : 192.168.2.x is it ok ?

It’s still not working though…

Best Regards,

Thank you for the information.

Could you please attach screenshots from RMS VPN → VPN hubs so I can review your configurations? Specifically, I’m interested in seeing the “Routes” and “Configuration” sections.

Best Regards,

First image is the configuration : // there is no DHCP configuration

Second are my routes

The one in yellow were automatically added through the “scan”

Third is my “client” :

Just to clarify, when you mentioned accessing the RUT901 WebUI remotely via the link, were you referring to the link in RMS Management → Devices → Actions?

I want to confirm if you can access your RUT901 specifically from the RMS VPN hub (you can find your RUT901 VPN IP in the VPN hubs General section). You should be able to access the router using its VPN IP (192.168.2.X).

Please clarify this so we can proceed with troubleshooting further.

Best Regards,

I can access it from this button yes

I can’t acess it from the RMS VPN HUB :

But on my local Lan it’s adress is, is this the adress I shall give it in VPN hubs ==> Devices ?
I think my problem must be in those configurations, cause I can’t access it, but I don’t know where…

Best regards


Thank you for providing screenshots. Firstly, we need to figure out why you can’t access your RUT901 via the VPN hub. Once you can access it, its LAN devices should be accessible as well.

First, please confirm that your device has the latest RUT9M_R_00.07.06.10 firmware version installed. If not, please upgrade it (you can download it from here).

I suggest trying to create a new hub following my instructions and see if it works now. If so, then we can add your specific configurations and devices.

  1. Log into your router’s WebUI, navigate to System → Administration → Access Control, and under ‘WebUI’, enable remote HTTP access.

  2. Scroll down to the end of the page and press ‘Save & Apply’.

  3. In RMS navigate to RMS VPN → VPN hubs and press ‘Add’.

  4. Enter your desired name for a VPN hub; select the Location, e.g. Bahrain; press ‘Create’.

  5. Open your created VPN hub, navigate to Clients, press ‘Add’, select RMS User you want to add, and then select RMS Device you want to add.

  6. Download the VPN configuration file.

  7. Open the OpenVPN Connect app and upload file with VPN configuration you have downloaded.

  8. Press ‘Connect’.

  9. Open your RMS VPN hub, navigate to the General section and copy IP address next to your RUT901.

  10. Paste this IP to your browser, and you should able to access your router’s WebUI login page.

After completing these steps, let me know if you are able to access your RUT901 via the RMS VPN IP.

Best Regards,

Hi Marija,

I just completed this steps and it’s ok the remote access via the RMS VPN IP works.
It’s not in the same subnet than my equipment does it matter ?

How do I configure my equipment so that I can access them remotely ? (they are in subnet 192.168.0.x)

Thant you for your help :slight_smile:

I’m glad my instructions helped you access your RUT901 via the RMS VPN IP!

Regarding your question, when creating routes in the VPN hub, if you add devices manually, you should use the IP addresses they have on your RUT901 LAN (192.168.0.X). Similarly, when using Auto Scan, you will see equipment connected to your RUT901 with their LAN (192.168.0.X) IP addresses.

Now, let’s proceed to the second step and attempt to add LAN devices automatically.

  1. Navigate to the ‘Routes’ section of your created VPN hub. Enable ‘LAN’ next to RUT901 and click ‘Add route’.

  2. In the ‘Auto Scan’ section select your RUT901 and click ‘Scan device’.

  3. After scanning, you should see a list of devices connected to your RUT901.

Please let me know if you see this list. If not, we can try adding devices manually.

Best Regards,

Thank you :slight_smile:

So, I did the autoscan. But unfortunately I don’t see my equipments, there are a lot of IP adresses and I don’t know why they are there but not my equipment’s… I also don’t see my teltonika in the equipments. (with the autoscan)

So i believe I need to configure them manually… For the parametres here : the client is supposed to be my RUT901 right ?

Okay, I understand. In the auto-scan, you won’t see your RUT901 because it only displays devices connected to your RUT901. The reason you see ‘Teltonika’ in my auto-scan is because I have connected another Teltonika router to my RUT956.

Now, let’s check if the equipment connected to your RUT901 is reachable from the Teltonika device.

  1. Can you please specify how your equipment is connected to your RUT901 LAN? Are they connected via Ethernet cable to the LAN port, or are they connected via WiFi?
  2. Also, please try connecting to your RUT901 via the CLI and attempt to ping the LAN IP (using the command ‘ping 192.168.0.X’) of a few equipment connected to your RUT901. Are the pings successful? All of them?

The equipments are connected via Ethernet cable to the LAN port. No wifi is connected/set.

I did ping a few of them and the pings are working on the CLI.

What is the next step ? :slight_smile:

Thank you for confirming that your equipment is reachable from the Teltonika device!

Now, let’s try to manually add one of your equipment to the VPN hub.

  1. In the IP address section, enter your equipment’s LAN IP (192.168.0.X).

  2. In the Netmask section, enter

  3. In the Clients section, select RUT901 and click ‘Add’.

  4. Click ‘Restart hub’.

  5. After restarting the hub use the IP address of your equipment and try pasting it into your web browser.

In my case, for tests, I’m using another Teltonika (RUTX11) router connected to my RUT956 LAN port via Ethernet cable, and I can reach it after configuring a route in RMS VPN hub:

Please try completing these steps and let me know if you can now reach your equipment. Don’t forget to enable the remote access function on your equipment if it has one.

I just did this configuration and I could access one equipment !!! Great win thanks a lot for your patience and help :slight_smile:

You’re welcome!

Feel free to reach out if you have any more questions or need assistance with configurations.

Best Regards,