Using RUT955 as a Modbus TCP to RTU via rs232 gateway

I followed the bouncing ball for configuring a Modbus TCP / rs232 gateway

Problem is that it appears to not do any gatewaying

I have established a Modbus poll workspace which works perfectly when
polling a DeepSea E800 controller.
When - both through its ethernet via ModbusTCP and via RS485 through a USB adapter.
When I point to the RUT955 “gateway” address everything comes up
illegal data address

_except a profile which I accidentally created and then optimized…
which reads from address 8 through 17.
After I failed to get any joy via RS232, and after I verified that direct polling via RS485 was working OK, I switched the RUT955 gateway config to use rs485 instead.
Still no joy. Some observations:
I was getting Illegal data address errors even before I had connected the RS232 cable
and the address 8 to 17 data was appearing… I thought something is up…

Sure enough this RUT had been configured for some telemetry gathering and portal pushing… I turned all that stuff off and after a bit more fiddling I managed to power through and get the Gateway via RS485 working and then after a bit more fiddling I had it working via RS232 too…
When fiddling around, it is easy to lose track of previous tweaks - like modbus IDs
So I can confirm that both scenarios work… Either the obtain config from TCP will pass on the ID or user-define can be forced to the specific ID one specifies…

BTW, a straight serial cable actually works :slight_smile:
I remember the bad old days of RS232: null modems and gender changers and hardware handshaking and plenty of farting around to get stuff going - whereas now with RS485 its a friggen multi-drop breeze!

So Thanks for watching as I worked through the advanced troubleshooting session and managed to get everything flying…
It would be good for the instructions to specifically emphasize the need to turn off other modbus monkey business such as would create slave-traffic in unexpected places :slight_smile: and actively interfere with the modbus TCP to serial gatewaying…

Technically the RUT firmware / OS should advise that “you’re doing dumb stuff that won’t work”

This topic was automatically closed after 15 days. New replies are no longer allowed.