Unknown package 'modem_updater'

I have several rut955 with EC25-EU modems.
I need to update them to version RUT9_R_00.07.05 because… there is finally a normally working NTRIP client.
However, I encountered a problem that on versions newer than 7.01.2 my mobile network stops working.
Modem software version - EC25EUGAR06A06M4G_01.005.01.005

I can’t update the modem because… The modem_updater package is not installed. I’m facing the “Unknown package ‘modem_updater’” error.
I also did not find this modem in the repository.

Can someone send me this package to update the modem?

Run ‘opkg update’ before it and make sure that router has wired WAN or working as WiFi client, otherwise you won’t be able to perform an update.

Yes, that’s exactly what I do.
The ‘sshfs’ package is installed, but ‘modem_updater’ is not listed.
‘opkg list | grep modem_updater’ also does not show such a package.

Could you update to newer RUTOS version?


Yes, updating to a newer version should help. And if it still does not fix the issue you can try executing these commands instead:

opkg -e /etc/opkg/openwrt/distfeeds.conf update
opkg -e /etc/opkg/openwrt/distfeeds.conf install modem_updater

Kind regards,

I’ve tried many versions already. including RUT9_R_00.07.06.10_WEBUI.bin.
The newest one on which the gsm modem continues to work is, but this version does not have an NTRIP client.

And as a result of all the manipulations, I encountered a problem that ntrip stopped automatically connecting to the version that I used earlier RUT9XX_R_00.06.08.5. Resetting to factory settings does not help.
However, if I try to run ntripclient through the cli using the command “ntripclient -s ‘server’ -r ‘port’ -m VOLV -u login -p password -M n”, then it successfully connects to the server and accepts the amendment.

But here, too, I encountered the difficulty that I cannot transmit this correction to rs232.
When I specify -D ttyS0, the session starts, but I don’t see anything on rs232.
I also don’t understand how to force nmea to be sent via cli from the built-in GPS receiver.
“help” describes only the transmission of a fixed nmea string.

I get an error loading “vuci”
I also don’t see this directory through the browser.

Downloading https://downloads.openwrt.org/releases/21.02.0/targets/ath79/generic/packages/Packages.gz                                                   
Updated list of available packages in /var/opkg-lists/openwrt_core                                                                                      
Downloading https://downloads.openwrt.org/releases/21.02.0/packages/mips_24kc/base/Packages.gz                                                          
Updated list of available packages in /var/opkg-lists/openwrt_base                                                                                      
Downloading https://downloads.openwrt.org/releases/21.02.0/packages/mips_24kc/luci/Packages.gz                                                          
Updated list of available packages in /var/opkg-lists/openwrt_luci                                                                                      
Downloading https://downloads.openwrt.org/releases/21.02.0/packages/mips_24kc/packages/Packages.gz                                                      
Updated list of available packages in /var/opkg-lists/openwrt_packages                                                                                  
Downloading https://downloads.openwrt.org/releases/21.02.0/packages/mips_24kc/routing/Packages.gz                                                       
Updated list of available packages in /var/opkg-lists/openwrt_routing                                                                                   
Downloading https://downloads.openwrt.org/releases/21.02.0/packages/mips_24kc/telephony/Packages.gz                                                     
Updated list of available packages in /var/opkg-lists/openwrt_telephony                                                                                 
Downloading https://downloads.openwrt.org/releases/21.02.0/packages/mips_24kc/vuci/Packages.gz                                                          
*** Failed to download the package list from https://downloads.openwrt.org/releases/21.02.0/packages/mips_24kc/vuci/Packages.gz                         
Collected errors:                                                                                                                                       
 * opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02.0/packages/mips_24kc/vuci/Packages.gz, wget returned 8.               

modem_updater is also not available.
Can you send me this package directly by email?


Just to clarify, these instructions were meant for version 07.xx.xx, not 06.xx.xx. Please make sure to update it to the 07.xx.xx version before downloading the modem_updater.

Also, I forgot to mention, have you tried updating the modem through the firmware update section in System → Firmware → Firmware update?

Best regards,

I see this. Latest version. There are no updates for the modem, but apparently there should be.

updating via “rut_fota” also fails.

root@Teltonika-RUT955:~# rut_fota -i                                                                                                                    
[connect_to_server:79] error: Failed to resolve connection host IP address                                                                              
[create_connection:39] error: Failed to connect to server                                                                                               
[connect_to_server:79] error: Failed to resolve connection host IP address                                                                              
[create_connection:39] error: Failed to connect to server                                                                                               
[connect_to_server:79] error: Failed to resolve connection host IP address                                                                              
[create_connection:39] error: Failed to connect to server                                                                                               
[main:477] error: Communication has failed                                                                                                              
root@Teltonika-RUT955:~# ping                                                                                                                   
PING ( 56 data bytes                                                                                                                   
64 bytes from seq=0 ttl=115 time=62.358 ms                                                                                                     
64 bytes from seq=1 ttl=115 time=61.908 ms                                                                                                     
64 bytes from seq=2 ttl=115 time=61.993 ms                                                                                                     
--- ping statistics ---                                                                                                                         
3 packets transmitted, 3 packets received, 0% packet loss                                                                                               
round-trip min/avg/max = 61.908/62.086/62.358 ms                                                                                                        

I installed all the updates via the bin file from the downloads page.


Can you check what credential the FOTA server is using on your device? To do this execute the command:

cat /etc/config/rut_fota

The regular output should resemble this:


Kind regards,

I have a little more lines.

config rutfota 'config'
        option logfsize '5242880'
        option logfile '/tmp/log.txt'
        option enabled '1'
        option check_after '86400'
        option communication_host 'rut.teltonika.lt'
        option communication_port '5000'
        option last_update '1712692321'
        option connection_state 'failed'

The configuration does not seem to be correct, you can try resetting it to default and test if it helps. Basically you can copy the default config with these commands:

cp /rom/etc/config/rut_fota /etc/config/rut_fota
/etc/init.d/rut_fota restart

This topic was automatically closed after 15 days. New replies are no longer allowed.