Unable to login via web ui

I have inherited a few RUT240 devices and the passwords given to me work for SSH login with the root user, but they do not work on the web ui on ports 9090/9943.

When I enter the credentials there is long loading process and finally a message:
“The device is unreachable. Please check the connection and try again.”

The username given to me is “Admin” but I have also tried “admin” and “root” to no avail.
The default admin:admin01 combination does not work either.

Is there a way to change or reset the web UI credentials when logged in as root via SSH?

I can’t reset the devices because they are in production use and I am not even fully sure on all the configuration they have.

The devices have firmware ‘RUT2_R_00.07.01.4’

Hello,

Our devices typically use the default WebUI ports 80/443 and 22 for SSH. Please keep this in mind. I regret to inform you that resetting passwords is not possible without a factory reset or a similar method if you are unaware of the existing password.

Normally, our devices come with the default username/password: admin/admin01. However, during the first login, you will always be prompted to change the password. Therefore, it is highly unlikely that the password remains as admin01 if the configuration has been applied.

It’s important to note that attempting to log in via SSH will require the same password as the one used for the WebUI.

Best regards,

Marijus

I can connect via ssh, but not via webui. Where are the webui accounts stored? Maybe I can see which usernames exist on the device.

Hi shunkica,

as @Marijus mentioned - the router’s WebUI is reachable via HTTP on port 80
and via HTTPS on port 443. The username on ssh is root, and the username on
the WebUI is admin. Both use the same password.

The port numbers can be changed via the WebUI’ menu at
System->Administration->Access Control but I’d try 80 and 443 first.

Regards,
Timelapse Admin

The solution was adding option _httpWanAccess '1' to /etc/config/uhttpd in the main section.

edit: I was wrong, adding that config command did not fix it. It looks like I could log in only directly after restarting uhttpd. Even then this only sometimes works.

1 Like

This topic was automatically closed 40 hours after the last reply. New replies are no longer allowed.