Two routers in one network


I have a setup consisting of the following:

  • Mikrotik MSG701 ( (Public IP)
  • Teltonika TRB140 ( (Public IP) ← My device
  • Sungrow Logger (, gateway

I can see and ping the device from the TRB140, but I can’t configure VPN or port forwarding to redirect the traffic to it.

I tried with and without DHCP, with relay. Teltonika is in the Bridge mode.

Can you suggest something?


Could you clarify the goal of this network configuration? I’m curious why there’s a Teltonika router between the Mikrotik and Sungrow Logger. What’s the purpose of this setup? Could you provide a bit more insight on how this network topology looks like?

Best regards,

We added our TRB140 as an independent gateway to access devices. The Mikrotik was there before.

We want to keep Mikorotik as it is and add our TRB140 alongside, with our VPN, etc.


What is the purpose of the Teltonika router? Why do we need two LTE routers on one network? Is it for redundancy? Also, which device serves as the DHCP server?

It is hard to understand what suggestion you need. Can you elaborate on this more?

Best regards,

The Grid Operator owns the Mikrotik, and only they can use it.

We need to access the devices using our devices. We have a VPN configured on the TRB to access the devices from the cloud.

The ideal option would be to configure TRB140 not as the router but as a gateway.


I am still working on it. I try to explain it better. We are SaaS platform that provides high-level SCADA.
We signed a contract with a client who had a solar farm. They have an LTE router that they are using.

They didn’t want to give us access to this router and requested us to provide the new device with our own internet access.

So, the situation before our installation looked like this:

  • LTE Router (DHCP server)
  • Logger (gateway
  • Controller (no gateway configured)

We wanted to add our device (TRB140) with independent internet to proxy traffic from our cloud to the Logger and Controller. So, we configured our gateway with static local IP ( and disabled DHCP.

The current situation is that the connection with the Controller works properly. We can configure the port forward, and everything is ok.

The problem is with the logger, where I can send requests from the Modbus client (from UI). Everything is ok, but the port forward doesn’t work. So the communication from the TRB140 to Logger is possible. The only thing that doesn’t work is routing from WAN to LAN.

Any ideas would be appreciated!

The interesting thing is that if I bypassed the whole router firmware and made a simple Python proxy, I could connect.

I’m looking for a way to make the TRB140 a simple proxy

Hello, you can try to set “Masquerade” for lan zone. This will fix source address from your cloud and Contoller will think that he is communicating with TRB.

I changed everything to Accept :slight_smile:

But still no luck.

When I try to connect using port forward:

I get a connection refused.

When I connect using a proxy script, everything works fine.

are you still enabled bridge mode? you should set TRB in NAT mode

I’ve finally figured it out!

Based on this article Websocket traffic forwarding using iptables ·

The only thing I needed to do is to add:

iptables -t nat -A POSTROUTING -p tcp --dport 80 -j MASQUERADE

in the custom rules in the firewall.

1 Like

This topic was automatically closed 40 hours after the last reply. New replies are no longer allowed.