TRB500 - Data connected if "Deny data roaming" is On

Hello All,
I can’t find any similar issue here :expressionless:

I need to block data roaming, to block data transfer to/from the internet, when Connection → Operator state is “Roaming”,
My TRB500 Mobile → “SIM-card setting” “Deny data roaming” option is “On”, but allows data transfer in this case, it is reachable remotely and it can ping any internet host for example.
What is wrong, misunderstand or misconfigure by me?

Thank you in advance

Hello, what is registration status to the network? Could you post info from WebUI when you in Status → Network → Mobile? Are you sure that current state is “Roaming”?

Hello, Yes, I can, see below.
PS: The connection status hint is “* Mobile data is not allowed when roaming”

Maybe you enabled data connection with mobile utilities or something like that?

If you disable this option, save configuration and enabled one more time, is this still not working?

I didn’t, and I don’t use any utilities except WebUI,
Do you mean to switch the “Deny data roaming” option on/off and to restart mobile connection?

Yeah, try disable, save configuration, wait while connection will be reestablished and then enable.

The “Deny data roaming” logic works correctly when the mobile connection restarts manually.
I need to block data connection in roaming without any manual manipulations.
Last two changes of mobile operators in roaming didn’t block data connection :frowning:
PS: I’ll be able to check roaming behavior again tomorrow at least.

So from what are you saying, maybe this problem occurs when device is going from home to roaming network?

This issue occurs when TRB500 switches from home to roaming and when it switches between roaming operators as well.

PS: I’m not sure if I should create new topic, but is it possible to handle switching between operators, to identify home/roaming connection status by something, by hotplug for example, to do something on event?

It’s possible I think, using ubus and track events there.

Hello,
My TRB500 didn’t handle the “Deny data roaming” → “On” logic correctly today, it didn’t block data connection after switching from home to roaming network.
Is it possible to fix this issue? Do you have any solution to solve this issue?

What module firmware are you using?

The latest, as I see:
System firmware version: TRB500_R_00.07.06.8
Internal modem FW version: RG501QEUAAR12A07M4G_04.001.04.001

Could you post your contact?

Sure, my email is sensored

This issue might be solved in the TRB500_R_00.07.07 (2024.04.16) firmware release