TRB245 error Firmware 07.05 and higher

I use modem control via RS232 to send SMS by AT command.
Until version 07.04.3 everything worked well.
After updating to higher version a problem appeared. If the “full control” parameter of the modem via RS232 is already activated at startup, it gives me the information, on the RS232 “AT+CMS ERROR: 13” which is SIM Failure. And gets stuck like that, until I disable control via RS232 wait for it to get a data connection, then re-enable modem control via RS232. And there it works again until the next reboot.

Hello,

Could you share the Troubleshoot file with me?
We have sent you instructions to log in to the Hubspot system where we can manga safely read your file, and where is sensitive information allocated.

To download the file you need to go to: System->Maintenance->Troubleshoot

I have also found and read this topic - Regain control after +CME ERROR: 13 - Legacy / Open AT - Sierra Wireless Forum

Anyway, troubleshooting file can give to us more information.

Kind Regards

Hello, As a new member of the community, I cannot download an attachment. But I think it’s the moving part that interests us here.

[Thu Apr 4 10:29:39] Starting mobifd
[Thu Apr 4 10:29:40] [gsm.modem0] Setting up modem instance
[Thu Apr 4 10:29:40] [gsm.modem0] Active SIM: “1”
[Thu Apr 4 10:29:40] [gsm.modem0] Created new modem instance
[Thu Apr 4 10:29:40] [gsm.modem0] Registering unsolicited listener
[Thu Apr 4 10:29:40] [gsm.modem0] Modem features were parsed successfully
[Thu Apr 4 10:29:40] [gsm.modem0] Starting modem settings init
[Thu Apr 4 10:29:40] [gsm.modem0] Skipping modem initialization due to RS modem full control being enabled
[Thu Apr 4 10:29:44] [gsm.modem0] PIN state event: “SIM not inserted”
[Thu Apr 4 10:29:44] [gsm.modem0] Mobile state: “Unknown state”
[Thu Apr 4 10:29:44] [gsm.modem0] Modem will be reloaded due to PIN state “SIM not inserted”
[Thu Apr 4 10:29:44] [gsm.modem0] Canceling uloop timeouts
[Thu Apr 4 10:29:47] [gsm.modem0] Performing config reload
[Thu Apr 4 10:29:47] [gsm.modem0] Config reload initiated
[Thu Apr 4 10:29:47] [gsm.modem0] Canceling uloop timeouts
[Thu Apr 4 10:29:47] [gsm.modem0] Finishing modem config reload
[Thu Apr 4 10:29:47] [gsm.modem0] Active SIM: “1”
[Thu Apr 4 10:29:48] [gsm.modem0] Skipping modem initialization due to RS modem full control being enabled
[Thu Apr 4 10:30:40] [gsm.modem0] Removing modem instance with UBUS ID: -1758675104
[Thu Apr 4 10:30:40] [gsm.modem0] Canceling uloop timeouts

If I understand correctly it cannot find my SIM card in slot 1.
Sorry for my English which is not very good.

Hi,

I have read troubleshoot file, nothing wrong with configuration from first sight, i will consult with my colleagues we will try find out what the situation

kind regards

Hi,

Let me know if you tried it once time with new firmware or if you already downgraded to 07.04.3 and check if it is all fine.
So you can go back to 07.04.3 check is problem away and then upgrade to a newer version to check if the problem turns back, after that let me know the results, if the problem persists with a newer version, there is probabbly a firmware issue.

Also, we have newer firmware 07.06.10 you can try with it, but without saving configurations or make factory reset after upgrading - TRB245 Firmware Downloads - Teltonika Networks Wiki (teltonika-networks.com)

Kind Regards.

Hi,
First try was with version 07.04.3 which worked.
I updated to 07.06.6 the problem appeared.
Return to version 07.04.3 function.
Test 07.06.6 without keeping the configuration, redo the configuration manually, problem still there.
Back in 07.04.3 function.
Test 07.05.4 problem appeared.
Test 07.06.10 problem still there.

Kind Regards

Do you make default settings on 07.06.10 and config RS with full control from scratch ?
Is that correct what I understand?

On version 07.06.6 yes, on 07.6.10 I have a doubt, I will ask immediately
Kind regards

I have version 07.06.10. reset the factory settings and redone
RS232 full control parameters and reboot. the same I always have the CME Error:13 message coming back.
Kind regards

Ok, good, thaks for reply, we will proceeed with that information, I`l contac you ASAP.

Hi,

We have made some tests, and after reboot, all goes fine.

Could you please insert another sim card, its just for testing purposes, maybe some negotiations cant be normally passed after bootup and an error appears it`s just my suggestion.

Kind Regards

Hi,
I tested with another SIM card and even with both,
I always get the answer +CME ERROR: 13
here is my initialization session:
ATH&FE0S0=1
OK
AT+CPIN?
+CME ERROR: 13
What if I deactivate the “Modem Control” 10 seconds
SMS functions but not DATA. I have to wait 40 seconds for the DATA to work too.
Kind regards

So in general when you disable “full controol” it goes back normal data transmition after 40sec and SMS start run normally after 10sec, is that correct ?

Not everyone did,
If I deactivate “full control” for 10 seconds and reactivate it, only the SMS will work again. The apparently time it takes for the TRB245 to initialize the modem and take the signal from the provider.
I need to leave the “full control” deactivated for at least 40 seconds so that the TRB245 can have the DATA connection and reactivate the “full control” to have the DATA and SMS.
PS: I work without a PIN Code.

Hi,
I did some tests again,
Under 07.04.3 when I reboot the TRB I can see in overview that the modem resets, picks up a signal and connects to the provider and only then goes into “Full control” mode and gives me every 2 seconds +QCSQ: “LTE” ,77,-106,128,-13

Whereas under 07.06.10 when I reboot it I don’t see the modem being initialized it goes directly into “Full control” mode and it’s only when I stop the “full control” that initializes the modem connects and then I can reactivate the “full control” for which gives me the +QCSQ: “LTE”,77,-106,128,-13 every 2 seconds too.

Is there an AT command to activate the modem?

Hi,

It seems the modem does not activate under booting by firmware, and immediately goes to full control mode, try to use AT+CFUN=1 , that command enables modem, but I think there should be a first initialisation from OS, for that case I need to consult with my colleagues.

Thank you for additional information!

Kind Regards

I recieve feedback, and that is corrected behaviour as it should be on device, from 07.05, that was fixed, to enabling manually by user only - TRB245 Firmware Downloads - Teltonika Networks Wiki (teltonika-networks.com)
image

Hi,
Ok, too bad it was very practical and it corresponded to the other modems used so far. The AT+CFUN=1 command only works for the SMS modem, not for DATA and I cannot find the AT command to activate the DATA connection.
Kind regards

Hi,

Her is AT commands to cinfigure data:
AT Commands: Introduction, commands for a proper network connection/disconnection and device configuration examples – emnify

Kind Regards