TRB145 Data to Server - Modbus/MQTT - remove brackets

I am sending Modbus Data via MQTT to AWS :slight_smile:

Below is my payload - i cannot find a way to remove the brackets.

I have configured ‘send as object’ off in Data to Server but still getting the brackets

I am running ver 7.05.4

Any help much appreciated


Welcome to Teltonika Networks Crowd Support!

To eliminate the bracket, access the WebUI → go to Services → Modbus → Modbus Client. From here you can enable the Bracket option. This instance enables the removal of brackets in the Modbus Data similar to this.

Also, in Data to Server under Collection Configuration, choose Custom in Format type. From there you can remove the open and close brackets of the data.

Let me know if this cleared your doubts.


thanks Janmiguel,

I have tried both these options, but neither option removes the outside brackets.

It looks like the system is treating the “custom” format as a string and not as JSON and then wrapping it in JSON.


I did a simple local testing where I am pulling out Modbus Data from itself then sending the data to a local HTTP Server. Below are my configuration and results.


Can you share your configuration for the same/


firmware 07.05.4


If you want to remove the brackets that are marked red, make sure that you remove the bracket under Collection Configuration as per below.


All sorted - many thanks

This topic was automatically closed after 15 days. New replies are no longer allowed.