TRB143 MBUS meter to HiveMQ MQTT Broker sevice?

I found a guide for TRB245 but for ModBus and it gave me a few ideas on how the certificates has to work but I still cannot get any Mbus data to flow from TRB143 to the Cloud service!

The Mbus side is working and i can see meter value there by the “Test” function.
I have tried soo many ways to get the rest to work so I am now hoping for some guidence here please!

Link to the similar guide for ModBus:


Are you using Data to Server or some other service?

Where are you trying to send your data? What platform?

Could you please share you current configurations? Before you share them here, make sure you hide/blur any sensitive information, like public IPs, connection strings, passwords, etc.

Kind Regards,

Hi AndzejJ

I have tried both the “Data to other Server” and also the “MQTT Publisher” with the right certificates in place according to the old guide for ModBus I linked to in my first post.

The platform I try to use is HiveMQ MQTT Broker service, just like in the older Modbus guide.

I use wired ethernet that has a working internet connection. No GSM.

Hello @ingo69,

Apologies for the delayed response.

It seems that you have port 1883 configured. Could you please try setting in to port 8883?

If this does not help, HiveMQ should have a public broker available that can be used without TLS. Could you please try that and see if it works? This will help us to see if the issue is with Certs/TLS/Authentincation.

Kind Regards,

Hi AndzejJ
I feel stupid, it was just the IP port that was wrong!

Many thanks for your help!

1 Like

This topic was automatically closed after 15 days. New replies are no longer allowed.