TRB141 not connecting to AWS Mqtt broker

My TRB141 won’t send any data to the AWS iot Core mqtt broker. After creating a ‘thing’ in AWS I downloaded the certificates and uploaded to TRB141, and followed the instructions mentioned elsewhere on the teltonika forum, but I’m not receiving anything in AWS. I also tried using the same certificates on another device (rpi using node-red) and this worked fine.

This is what my config looks like:


Could you please clarify if you are using credentials (username/password)?

Have you tried enabling the ‘TLS insecure’ option?

Also, did you acually send MQTT messages to request/response topics as described here?

Have you tried using Data to Server functionality? Do you receive data then?

If this does not help, could you please try a different broker to see if the issue is related to communication between TRB141 and AWS specifically.

Kind Regards,

I’m not using username/password. I’m using CA+certificate+key files. Yes I tried the insecure option, it didn’t change anything. I notice that in some screenshots the QOS is set to 2 - is this a requirement?
I have used Data to Server, which in a previous firmware did work but now does not. What I really need to work is the MQTT Modbus gateway, because I need to send commands over MQtt to the device. And finally, yes using another mqtt broker (using username and password) all of this works.


Are you on the latest firmware version?

I have tried to replicate, but everything works:

Kind Regards,

I forgot to mention , we’re running all our devices through WireGuard vpn - could this be a problem?

I’m running on TRB1_R_00.07.04.3.


Do you route all of the traffic via WireGuard? Would it be possible for you to disable it and see if you are able to connect then?

Could you please try navigating to Network → Interfaces → edit LAN and specify custom DNS servers? Try and

While it should work fine with your firmware version, I would still suggest to update if this does not work for you. When updating, it is recommended to disable the ‘keep settings’ option to ensure proper migration.

Kind Regards,

I only need to be able to reach the device remotely via WireGuard, but I don’t know how to configure the vpn so that it excludes all mqtt traffic?


Have you tried adding a DNS server to your LAN interface?

What are your wireguard settings? Could you share those? Make sure to hide Public IP addresses and keys. Also, please, access the command line of the device (instructions here) using ‘root’ as the username, execute the following command and share the output:

route -n

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.