TRB140 - RutOS 7.5 - SMS Gateway not working

Morning guys
I’ve just been trying out RutOS 7.5 on our TRB140 and found that the SMS gateway isn’t working after upgrading.
We use the gateway to forward received SMS’s to an API address as well as to emails. The device also didn’t show up any messages in “Services” - “Mobile Utilities” - “Messages” - “Read Messages”. Messages weren’t being emailed either.

I’ve rolled back to the latest version of 7.04 and confirmed everything is working properly after downgrading.

Is there a better way to submit feedback/bug reports with the new firmware?



I have tried to replicate this issue, but was unable to. SMS was forwarded to both, my HTTP server, and to my email.

First, could you please clarify if you updated the firmware with ‘keep settings’ enabled? If so, have you tried resetting the device to factory defaults after the update?

If you reset the device on v7.05 firmware version and the issue persists, could you please share your configurations and steps to replicate this?

Kind Regards,

@AndzejJ Thanks for the tips
I can confirm that I had “keep settings” enabled.
Next time I’ll try upgrading to 7.05 with a factory reset and manually configuring SMS forwarding after the reset.
Give me a couple of days and I’ll let you know how it worked out.


Sure. Let me know how it goes. If there are still issues, please share screenshots of your configurations.

Kind Regards,

Can confirm a firmware upgrade but not retaining settings has worked.
Messages are displaying properly, forwarding through to the API and being retained as a single message, not split into their component parts.
Sent through a 600 character text message with emojis and it all came through the way it should!

Happy camper

1 Like

This topic was automatically closed after 15 days. New replies are no longer allowed.