TRB140 not connecting to RMS

My TRB140 device is not able to connect to RMS. The behaviour is quite strange:

  • when I connect directly to the device through LAN, in the “Cloud solutions” section, the device’s status is “Enabled”, and the connection state “Connected”
  • however, in RMS, the device remains “not activated”
    I tried several times to unregister and register again, the situation remains the same.

What could be wrong ?
Thank you in advance for your help!

Did you activate the service in RMS?

How to do that you can see here:

RMS Multi Year Credit Activated - #10 by wvsdmarius

Yes, I think so : I bought 12 credits for the company and activated it.
From what I read, having a “pack” is not mandatory as far as I have credits. Am I right ?

Hello @Alexandre
The device is able to reach Teltonika’s RMS system, but it’s not able to reach your company RMS. From what you have writen I can see that you already have tried multiple times to register and unregister.

Could you in your Company RMS portal go to “+Add”.
Make sure that the correct company is selected in the section “company”. (You should select the company that has the RMS credits.)
Make sure that you select TRB in the section “Device series”.
Add your hostname, serial number, IMEI and the password that you used to login to the TRB140 device itself. If everything is correct it should be added into your company RMS

You can find both the serial number and the IMEI number under the TRB140 device.

Hello @Z2SY9KfynT0R
Thank you for your answer.
I think the problem was eventually resolved when I updated the firmware. My device was bought a couple of years ago and was still under firmware version 0.1. I updated to 0.7 and it connected.
Best regards

Good to hear you solved your issue :slight_smile:
Yes - always make sure you’re using the latest available software.
Many issues will solve by themselves then…
Happy routing!