TRB140: how to enable remote (WAN) WebUI from ssh access


I have a TRB140. Is it possible to enable remote (4G) WebUI from ssh access? Before deployment, I forgot to enable WebUI access from 4G, is ot possible to enable it from SSH (luckily I have enabled that).

For those who stumble here, this is the solution:

  1. First you need to allow the server to be accesed from the wan port:
uci set uhttpd.main._httpWanAccess='1'
uci commit uhttpd
  1. You need to restart the www server of the router:
/etc/init.d/uhttpd restart
  1. You need to find the firewall rule that controls access to port 80 from WAN:
uci show | grep fire | grep "'80'"


  1. If you got this as reponse, let’s check the complete rule:
uci show | grep firewall.16 

and you got this response:

  1. The last line tells you that the firewall rule is disabled (essentially the route is banned), so let’s enable it:
uci set firewall.16.enabled='1'
uci commit firewall
  1. We have to restart the firewall:
/etc/init.d/firewall restart

And that’s it!

Note: this solution may work for all RUT-s and TRB-s, as long as you fine the correct firewall rule…

This topic was automatically closed after 15 days. New replies are no longer allowed.