TRB 140 EMM & ESM error

TRB 140 version:- [TRB1_R_00.07.07.1]
Data connection is not getting established, Network signal is -67dBm im using JIO sim card on this the sim code is 405869. The same sim card checked in mobile internet is working fine and i can make call and SMS.
Im getting this below error:

  1. Mobile EMM reject cause: ESM failure
  2. Mobile ESM reject cause: Request rejected by Serving GW or PDN GW
    Please kindly help on this.


I suggest checking which APN you’re using. It seems like there might be APN issues causing your mobile data connection to be rejected.

You can find APN settings under Network → WAN. Click on “Edit” next to the active mobile interface. A new pop-up window should appear where you can disable “Auto APN” and enter the correct APN.

Best regards,

Thank you Marijus data connection established its working.
Now While change the Lan Configuration the device go restart after that, i can’t able ping the IP and configuration page also not opening.
i have tried by press the reset the button then also it not working.


Have you made any extra changes, such as switching the “Mode” to “Bridge” or “Passthrough,” or anything else?

Either way, try finding out the address of your router. You can do this by opening CMD and typing ipconfig. The default gateway is the address of your router.

Best regards,

i can’t find my router address.if there is any other way to find out.


i have tried with ip scanner to find the IP also, i can’t find it. its serial no: 1125422168 & Batch no: 054.
is there any other way like USB or other way.


It seems from the image you provided that the TRB140 is connected, and its DHCP server is assigning an IP address to your computer. It’s puzzling why you can’t ping it. Could you provide the output of the command “ping”?

Also, since it’s the second network adapter, is your computer connected to any other network at the same time?

Best regards,

Lan is connected with TRB140 router & WIFI for internet is connected. Pls find the ping CMD for your reference

It looks like your PC is NOT getting its IP address via DHCP and your router has a different IP.
Can you make sure to set your PC to DHCP?
Then see automatically assigned Default Gateway (= your router) and try to ping it again.

now DHCP is enable. still not getting ip reply

Yes because your PC doesn’t receive an IP address from your router:


Can you reset your router to factory defaults?

TRB140 Device Recovery Options - Teltonika Networks Wiki

[Look for reset button method]

Then your previous APN issue and DHCP will work nicely again :wink:

And as @Marijus said - always make sure you’re not connected to another network at the same time!


Thankyou for your support… after factor reset it working fine. internet also connected.
why its showing as like in IPV4. can you please tell me

I can: because you’re online via IPv6:


To change that, set it to IPv4 only:

1 Like