TLS key negotiation failed to occur within 60 seconds (check your network connectivity)

I would like to set up OpenVPN in TAP mode on Teltonika RUTX50 routers.

- 1 Teltonika router as server 
- 2 Router as client 

One of the clients connects well to the Openvpn server, but the second client can’t connect.
In the server logs I could see the errors below:

[daemon.err openvpn(PC)[8607]: TLS Error: TLS key negotiation
failed to occur within 60 seconds (check your network connectivity)
daemon.err openvpn(PC)[8607]: TLS Error: TLS handshake failed]

Has anyone ever had this type of problem? If so, how did you solve it?

Thanks in advance.


Are you using proper TLS certificates on all devices? Have you tried generating new ones?

The error is quite generic and there can be many things that can cause this.

Maybe you could share more OpenVPN logs?

Generally, you can find OpenVPN configuration examples here.

Kind Regards,


Thank you for your feedback.
I’ve just found the cause of the error.
In fact the error was linked to the difference in clocks between the server and the client.
After synchronizing the two clocks it worked.
If anyone else has this problem:
- Please check the firmware version between client and server
- Check that client and server have the same clock.

YES, I’m using the example in this link: OpenVPN configuration examples RUT R 00.07 - Teltonika Networks Wiki in TAP mode configuration.

In this example, we have one client and one server. Is it possible to have two clients and one server? So that the two clients can talk to each other via the server in the same LAN?

I’ve currently set up this configuration with two clients connecting to the server, but I’m noticing regular disconnections.

Thanks for your help