Ssh config file on rut956


I’ve first sucessfully upgraded the firmware of my rut956 via SSH via sysupgrade commande line. to 07.05.04 release.

I’ve then tried to the the same for the backup-rut.tar.gz but it does not work as expected →

root@RUT956:/tmp# sysupgrade backup-RUT-2024-08-04.tar.gz
Tue Nov 7 13:47:29 UTC 2023 upgrade: Image signature not present
Tue Nov 7 13:47:30 UTC 2023 upgrade: Image metadata not present
Tue Nov 7 13:47:31 UTC 2023 upgrade: Use sysupgrade -F to override this check when downgrading or flashing to vendor firmware
Tue Nov 7 13:47:31 UTC 2023 upgrade: Firmware metadata not found
Tue Nov 7 13:47:32 UTC 2023 upgrade: Firmware metadata not found
sh: out of range
sh: out of range
sh: out of range
Image check failed.

I’ve tried with -F and then my rut956 is not responding anymore …


It seems there might have been a misunderstanding in how you used the sysupgrade command, possibly without prior research.

Restoring the configuration from a backup file should be done using this command:

sysupgrade -r /tmp/backup-RUT-2024-08-04.tar.gz

The -F flag option should not be taken lightly. In the sysupgrade -h command, it’s stated that -F “Flash image/restore backup even if image checks fail, this is dangerous!”

Could you provide the exact command you executed that led to your device being bricked?

Additionally, your device might not be bricked. Have you tried doing a factory reset or reaching the device via the bootloader menu? Here is how to do it: RUT956 Device Recovery Options - Teltonika Networks Wiki

Best regards,


thank you for the explanation. I coulnd not find the sysupgrade -r in your documentation.

I’ve tried to do a factory reset without success unfortunately.
I’ve observed thie behavior →

  • after factory reset I reboot the devis (power cycle)
  • directly after power supply again the devic ping for a few second
  • a web page opens also for a few seconds
    *the device does not ping anymore

see screenshot below


ok got it via bootloader

seems to work now


You can find information about this command (as with any other) using the command name followed by the flag -h or --help. In this case, it should be:

sysupgrade -h

Please try accessing/recovering the device via the bootloader menu. Here are the instructions: RUT956 Device Recovery Options

Best regards,

It worked, thank you. I also see that sysupgrade -r does not change the IP adress directly , the device needs to reboot ?


To activate the backup, the router needs to reboot. When backing up via sysupgrade, it must be done manually. However, using the WebUI automates this process.

Best regards,

hi, thank you,

is there also a way to change the pin code via ssh command ?

Yes, for this you can use command:



Kind regards,

are you sure is it going to change the pin code for the sim card ? in the config file


To change the SIM PIN, you can use the following command:

gsmctl -A AT+CPWD="SC","1234","4321"

The first number should be your current PIN, and the second one should be your new PIN.

If you have any questions about RUTOS or any other Teltonika device functionality, don’t hesitate to search inside the community forum. Most likely, somebody has experienced a similar problem and found a solution to it.

Best regards,

1 Like

aciu labai Marijus


1 Like


I’ve the same issue


To change the active SIM card, you would use the -Y flag, and to check which one is active right now, you would use the -T flag.


So the commands would look like this:

gsmctl -Y
gsmctl -T

Another simple solution would be to just take out the SIM card from the second slot and put it into the first one, and then change the SIM.

Best regards,

1 Like

This topic was automatically closed 40 hours after the last reply. New replies are no longer allowed.